summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am55
1 files changed, 9 insertions, 46 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index 24acb1d1e..9526d7d73 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -14,13 +14,14 @@
# You should have received a copy of the GNU General Public License
# along with GNU Mailutils. If not, see <http://www.gnu.org/licenses/>.
-DISTCLEANFILES = atconfig $(check_SCRIPTS)
-MAINTAINERCLEANFILES = Makefile.in $(TESTSUITE)
-EXTRA_DIST = \
- $(TESTSUITE_AT)\
- testsuite\
+include $(srcdir)/testsuite.am
+
+DISTCLEANFILES += package.m4
+EXTRA_DIST += \
+ package.m4 \
+ package.m4.in \
testsuite.inc\
- package.m4\
+ testsuite.am\
lib\
etc\
spool\
@@ -28,22 +29,6 @@ EXTRA_DIST = \
maildir\
mh
-## ------------ ##
-## package.m4. ##
-## ------------ ##
-
-$(srcdir)/package.m4: $(top_srcdir)/configure.ac
- $(AM_V_GEN){ \
- echo '# Signature of the current package.'; \
- echo 'm4_define([AT_PACKAGE_NAME], [@PACKAGE_NAME@])'; \
- echo 'm4_define([AT_PACKAGE_TARNAME], [@PACKAGE_TARNAME@])'; \
- echo 'm4_define([AT_PACKAGE_VERSION], [@PACKAGE_VERSION@])'; \
- echo 'm4_define([AT_PACKAGE_STRING], [@PACKAGE_STRING@])'; \
- echo 'm4_define([AT_PACKAGE_BUGREPORT], [@PACKAGE_BUGREPORT@])'; \
- } >$(srcdir)/package.m4
-
-#
-
## -------------------------- ##
## Non-installable programs
## -------------------------- ##
@@ -78,7 +63,7 @@ cwdrepl_LDADD = ${MU_LIB_MAILUTILS}
## Test suite. ##
## ------------ ##
-TESTSUITE_AT = \
+TESTSUITE_AT += \
cwdrepl.at\
fldel.at\
lstuid00.at\
@@ -89,28 +74,6 @@ TESTSUITE_AT = \
mime01.at\
smtp-msg.at\
smtp-str.at\
- ufms.at\
- testsuite.at
-
-TESTSUITE = $(srcdir)/testsuite
-M4=m4
-
-AUTOTEST = $(AUTOM4TE) --language=autotest
-$(TESTSUITE): package.m4 $(TESTSUITE_AT) $(top_srcdir)/testsuite/testsuite.inc
- $(AM_V_GEN)$(AUTOTEST) -I $(srcdir) -I $(top_srcdir)/testsuite testsuite.at -o $@.tmp
- $(AM_V_at)mv $@.tmp $@
-
-atconfig: $(top_builddir)/config.status
- cd $(top_builddir) && ./config.status tests/$@
-
-clean-local:
- @test ! -f $(TESTSUITE) || $(SHELL) $(TESTSUITE) --clean
-
-check-local: atconfig atlocal $(TESTSUITE)
- @$(SHELL) $(TESTSUITE)
-
-# Run the test suite on the *installed* tree.
-#installcheck-local:
-# $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
+ ufms.at

Return to:

Send suggestions and report system problems to the System administrator.