summaryrefslogtreecommitdiff
path: root/mda/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mda/Makefile.am')
-rw-r--r--mda/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/mda/Makefile.am b/mda/Makefile.am
new file mode 100644
index 000000000..866dc71b8
--- /dev/null
+++ b/mda/Makefile.am
@@ -0,0 +1,72 @@
+# Copyright (C) 2007-2019 Free Software Foundation, Inc.
+#
+# GNU Mailutils is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 3, or (at
+# your option) any later version.
+#
+# GNU Mailutils is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Mailutils. If not, see <http://www.gnu.org/licenses/>.
+
+SUBDIRS = lib . tests
+sbin_PROGRAMS = mda lmtpd
+bin_PROGRAMS = putmail
+
+mda_SOURCES = mda.c
+lmtpd_SOURCES = lmtpd.c
+putmail_SOURCES = putmail.c
+
+if MU_COND_DBM
+ LIBMU_DBM=${top_builddir}/libmu_dbm/libmu_dbm.la
+endif
+
+LDADD = \
+ lib/libmda.a\
+ ${top_builddir}/lib/libmuscript.a\
+ ${MU_APP_LIBRARIES}\
+ ${MU_LIB_SIEVE}\
+ ${MU_LIB_MAILBOX}\
+ ${MU_LIB_AUTH}\
+ ${MU_LIB_MAILER}\
+ @MU_AUTHLIBS@\
+ ${MU_LIB_MAILUTILS} \
+ @MU_COMMON_LIBRARIES@\
+ @LIBMU_SCM@\
+ @LIBMU_SCM_DEPS@\
+ @MU_LIB_PY@\
+ $(LIBMU_DBM)\
+ @GUILE_LIBS@\
+ @PYTHON_LIBS@\
+ @DBMLIBS@
+
+lmtpd_LDADD = \
+ lib/libmda.a\
+ ${top_builddir}/lib/libmuscript.a\
+ ${MU_APP_LIBRARIES}\
+ ${MU_LIB_SIEVE}\
+ ${MU_LIB_MAILBOX}\
+ ${MU_LIB_AUTH}\
+ ${MU_LIB_MAILER}\
+ @MU_AUTHLIBS@\
+ ${MU_LIB_MAILUTILS} \
+ @MU_COMMON_LIBRARIES@\
+ @LIBMU_SCM@\
+ @LIBMU_SCM_DEPS@\
+ @MU_LIB_PY@\
+ $(LIBMU_DBM)\
+ @GUILE_LIBS@\
+ @PYTHON_LIBS@\
+ @DBMLIBS@\
+ @MU_TCPWRAP_LIBRARIES@
+
+AM_CPPFLAGS = -I${top_srcdir} @MU_APP_COMMON_INCLUDES@ -Ilib
+
+install-exec-hook:
+ chown root:mail $(DESTDIR)$(sbindir)/mda
+ chmod 4755 $(DESTDIR)$(sbindir)/mda
+

Return to:

Send suggestions and report system problems to the System administrator.