summaryrefslogtreecommitdiff
path: root/mail/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am34
1 files changed, 20 insertions, 14 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 38400589a..169fc7ae7 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,5 +1,5 @@
## This file is part of GNU Mailutils.
-## Copyright (C) 1999-2019 Free Software Foundation, Inc.
+## Copyright (C) 1999-2024 Free Software Foundation, Inc.
##
## GNU Mailutils is free software; you can redistribute it and/or
## modify it under the terms of the GNU General Public License as
@@ -14,10 +14,9 @@
## You should have received a copy of the GNU General Public License
## along with GNU Mailutils. If not, see <http://www.gnu.org/licenses/>.
-YLWRAP = @MU_YLWRAP@
AM_YFLAGS=-vt
AM_CPPFLAGS = \
- @MU_APP_COMMON_INCLUDES@ @MU_AUTHINCS@\
+ $(MU_APP_COMMON_INCLUDES) $(MU_AUTHINCS)\
-DSITE_MAIL_RC=\"@SITE_MAIL_RC@\"
mailbindir=@MAILBINDIR@
@@ -25,15 +24,13 @@ mailbindir=@MAILBINDIR@
mailbin_PROGRAMS = mail
mail_LDADD = \
- ${MU_APP_LIBRARIES}\
- ${MU_LIB_MAILBOX}\
- ${MU_LIB_MAILER}\
- ${MU_LIB_AUTH}\
- @MU_AUTHLIBS@\
- ${MU_LIB_MAILUTILS}\
- @READLINE_LIBS@ @MU_COMMON_LIBRARIES@
-
-EXTRA_DIST = msgset.c
+ $(MU_APP_LIBRARIES)\
+ $(MU_LIB_MAILBOX)\
+ $(MU_LIB_MAILER)\
+ $(MU_LIB_AUTH)\
+ $(MU_AUTHLIBS)\
+ $(MU_LIB_MAILUTILS)\
+ @READLINE_LIBS@ $(MU_COMMON_LIBRARIES)
mail_SOURCES = \
alias.c\
@@ -51,7 +48,6 @@ mail_SOURCES = \
exit.c\
file.c\
folders.c\
- followup.c\
from.c\
headers.c\
help.c\
@@ -64,7 +60,7 @@ mail_SOURCES = \
mailline.c\
mailvar.c\
mbox.c\
- msgset.y\
+ msgset.c\
next.c\
page.c\
pipe.c\
@@ -88,6 +84,7 @@ mail_SOURCES = \
touch.c\
unalias.c\
undelete.c\
+ unread.c\
unset.c\
util.c\
version.c\
@@ -95,5 +92,14 @@ mail_SOURCES = \
write.c\
z.c
+BUILT_SOURCES = msgset.c
+EXTRA_DIST = msgset.y
+
+msgset.c: msgset.y
+
+.y.c:
+ $(BISON) -o $@ $(AM_YFLAGS) $<
+
+
SUBDIRS = . testsuite tests

Return to:

Send suggestions and report system problems to the System administrator.