summaryrefslogtreecommitdiff
path: root/libmailutils/cfg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmailutils/cfg/Makefile.am')
-rw-r--r--libmailutils/cfg/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/libmailutils/cfg/Makefile.am b/libmailutils/cfg/Makefile.am
index aad631d29..9d44284c9 100644
--- a/libmailutils/cfg/Makefile.am
+++ b/libmailutils/cfg/Makefile.am
@@ -1,5 +1,5 @@
# GNU Mailutils -- a suite of utilities for electronic mail
-# Copyright (C) 2010-2019 Free Software Foundation, Inc.
+# Copyright (C) 2010-2024 Free Software Foundation, Inc.
#
# This library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Lesser General Public
@@ -20,24 +20,30 @@ noinst_LTLIBRARIES = libcfg.la
libcfg_la_SOURCES = \
driver.c\
format.c\
- lexer.l\
- parser.y
+ lexer.c\
+ parser.c
localedir = $(datadir)/locale
AM_CPPFLAGS = \
- @MU_LIB_COMMON_INCLUDES@ -I/libmailutils\
+ $(MU_LIB_COMMON_INCLUDES) -I/libmailutils\
-DSYSCONFDIR=\"$(sysconfdir)\"\
-DLOCALEDIR=\"$(localedir)\"
EXTRA_DIST = \
lexer.l\
parser.y\
- parser.h\
- gylwrap.conf
+ parser.h
BUILT_SOURCES = parser.c parser.h lexer.c
-YLWRAP = @MU_YLWRAP@
+parser.c parser.h: parser.y
+lexer.c: lexer.l
+
AM_YFLAGS=-vdt
AM_LFLAGS=-dp
+.l.c:
+ $(FLEX) -o $@ $(AM_LFLAGS) $<
+.y.c:
+ $(BISON) -o $@ $(AM_YFLAGS) $<
+

Return to:

Send suggestions and report system problems to the System administrator.