summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 6661bec7c..f3fd07ecd 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,5 @@
## This file is part of GNU Mailutils.
-## Copyright (C) 1999-2019 Free Software Foundation, Inc.
+## Copyright (C) 1999-2024 Free Software Foundation, Inc.
##
## GNU Mailutils is free software; you can redistribute it and/or
## modify it under the terms of the GNU General Public License as
@@ -17,9 +17,9 @@
SUBDIRS = gnu .
AM_CPPFLAGS = \
- @MU_LIB_COMMON_INCLUDES@\
- -I${top_srcdir}/lib/gnu\
- -I${top_builddir}/lib/gnu\
+ $(MU_LIB_COMMON_INCLUDES)\
+ -I$(top_srcdir)/lib/gnu\
+ -I$(top_builddir)/lib/gnu\
@GUILE_INCLUDES@\
@PYTHON_INCLUDES@
@@ -27,9 +27,9 @@ lib_LTLIBRARIES = libmuaux.la
noinst_LIBRARIES = libmuscript.a libmutcpwrap.a
libmuaux_la_SOURCES = \
- daemon.c\
mailcap.c\
manlock.c\
+ mdecode.c\
signal.c\
strexit.c\
mu_umaxtostr.c\
@@ -60,3 +60,8 @@ if MU_COND_PYTHON
libmuscript_a_SOURCES += python.c
endif
+if MU_COND_UNISTRING
+ libmuaux_la_SOURCES += unistr_u8.c
+else
+ libmuaux_la_SOURCES += unistr_c.c
+endif

Return to:

Send suggestions and report system problems to the System administrator.