summaryrefslogtreecommitdiff
path: root/libmailutils/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-09-14 14:59:17 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-09-14 15:01:52 +0300
commit7b79a6edcda94d4224bc4cbbe47cb6dcf2ea42db (patch)
treedfbf43e0d6663b49c3ea3db93d15a2d2e793df10 /libmailutils/Makefile.am
parentd1d548e1473e5e87e42df174110d57a05b9402d1 (diff)
downloadmailutils-7b79a6edcda94d4224bc4cbbe47cb6dcf2ea42db.tar.gz
mailutils-7b79a6edcda94d4224bc4cbbe47cb6dcf2ea42db.tar.bz2
Rename mailbox/ to libmailutils/.
This change has been waiting since 2005-08-16 (aaab88142c8193f1), when libmailbox had been renamed to libmailutils. Back then MU was still under CVS, which didn't like renames.
Diffstat (limited to 'libmailutils/Makefile.am')
-rw-r--r--libmailutils/Makefile.am186
1 files changed, 186 insertions, 0 deletions
diff --git a/libmailutils/Makefile.am b/libmailutils/Makefile.am
new file mode 100644
index 000000000..f28b1bdbc
--- /dev/null
+++ b/libmailutils/Makefile.am
@@ -0,0 +1,186 @@
1## Process this file with GNU Automake to create Makefile.in
2
3## Copyright (C) 2000, 2001, 2002, 2004, 2005, 2006, 2007, 2008, 2009,
4## 2010 Free Software Foundation, Inc.
5##
6## GNU Mailutils is free software; you can redistribute it and/or
7## modify it under the terms of the GNU General Public License as
8## published by the Free Software Foundation; either version 3, or (at
9## your option) any later version.
10##
11## This program is distributed in the hope that it will be useful, but
12## WITHOUT ANY WARRANTY; without even the implied warranty of
13## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
14## General Public License for more details.
15##
16## You should have received a copy of the GNU General Public License
17## along with this program; if not, write to the Free Software
18## Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA
19## 02110-1301 USA
20
21INCLUDES = @MU_LIB_COMMON_INCLUDES@ -I${top_srcdir}/libmailutils
22
23YLWRAP = $(SHELL) $(mu_aux_dir)/gylwrap
24AM_YFLAGS=-vt
25AM_LFLAGS=-dvp
26
27SUBDIRS = testsuite
28
29lib_LTLIBRARIES = libmailutils.la
30
31localedir = $(datadir)/locale
32AM_CPPFLAGS = \
33 -DSYSCONFDIR=\"$(sysconfdir)\"\
34 -DSITE_VIRTUAL_PWDDIR=\"@SITE_VIRTUAL_PWDDIR@\"\
35 -DLOCALEDIR=\"$(localedir)\"
36
37EXTRA_DIST = \
38 errors\
39 muerrno.cin\
40 parsedate.y\
41 fgetpwent.c\
42 cfg_lexer.l\
43 cfg_parser.y\
44 cfg_parser.h
45
46libmailutils_la_SOURCES = \
47 acl.c\
48 address.c\
49 alloc.c\
50 amd.c\
51 argcv.c\
52 asnprintf.c\
53 asprintf.c\
54 assoc.c\
55 attachment.c\
56 attribute.c\
57 auth.c\
58 base64.c\
59 binflt.c\
60 body.c\
61 cstrcasecmp.c\
62 cfg_driver.c\
63 cfg_format.c\
64 cfg_lexer.c\
65 cfg_parser.c\
66 crlfdot.c\
67 crlfflt.c\
68 cstrlower.c\
69 cstrupper.c\
70 daemon.c\
71 date.c\
72 dbgstderr.c\
73 dbgstream.c\
74 dbgsyslog.c\
75 debug.c\
76 diag.c\
77 dot.c\
78 envelope.c\
79 fgetpwent.c\
80 file_stream.c\
81 filter.c\
82 filter_iconv.c\
83 fltstream.c\
84 folder.c\
85 freeitem.c\
86 gdebug.c\
87 gocs.c\
88 hdritr.c\
89 header.c\
90 iostream.c\
91 iterator.c\
92 ipsrv.c\
93 kwd.c\
94 linelenflt.c\
95 list.c\
96 listlist.c\
97 locale.c\
98 locker.c\
99 mailbox.c\
100 mailcap.c\
101 mailer.c\
102 mapfile_stream.c\
103 mbx_default.c\
104 mbxitr.c\
105 md5.c\
106 message.c\
107 memory_stream.c\
108 message_stream.c\
109 mime.c\
110 mimehdr.c\
111 mkfilename.c\
112 monitor.c\
113 msgscan.c\
114 msrv.c\
115 mu_auth.c\
116 muctype.c\
117 munre.c\
118 mutil.c\
119 muerror.c\
120 muerrno.c\
121 nls.c\
122 nullrec.c\
123 observer.c\
124 opool.c\
125 parse822.c\
126 parsedate.c\
127 permstr.c\
128 progmailer.c\
129 prog_stream.c\
130 property.c\
131 qpflt.c\
132 rdcache_stream.c\
133 registrar.c\
134 refcount.c\
135 rfc2047.c\
136 sha1.c\
137 secret.c\
138 server.c\
139 socket_stream.c\
140 stdio_stream.c\
141 stream.c\
142 stream_printf.c\
143 stream_vprintf.c\
144 streamcpy.c\
145 streamref.c\
146 strltrim.c\
147 strskip.c\
148 stripws.c\
149 strrtrim.c\
150 syslog.c\
151 system.c\
152 temp_file_stream.c\
153 ticket.c\
154 tcp.c\
155 url.c\
156 vartab.c\
157 vasnprintf.c\
158 version.c\
159 wicket.c\
160 xscript-stream.c
161
162BUILT_SOURCES = parsedate.c muerrno.c cfg_parser.c cfg_parser.h cfg_lexer.c
163MOSTLYCLEANFILES=
164
165parsedate.c: $(srcdir)/parsedate.y
166 $(YLWRAP) "$(YACC) $(AM_YFLAGS)" $< \
167 y.tab.c parsedate.c y.output parsedate.y.output \
168 -- -yy pd_yy
169
170cfg_parser.c cfg_parser.h: $(srcdir)/cfg_parser.y
171 $(YLWRAP) "$(YACC) $(AM_YFLAGS) -d" $< \
172 y.tab.c cfg_parser.c y.tab.h cfg_parser.h \
173 y.output cfg_parser.y.output \
174 -- -yy mu_cfg_yy
175
176cfg_lexer.c: $(srcdir)/cfg_lexer.l cfg_parser.h
177 $(YLWRAP) "$(LEX) $(AM_LFLAGS) $(LFLAGS)" \
178 $(srcdir)/cfg_lexer.l lex.yy.c cfg_lexer.c \
179 -- -yy mu_cfg_yy
180
181muerrno.c: errors muerrno.cin
182 $(AWK) -f $(mu_aux_dir)/generr.awk $^ > $@
183
184libmailutils_la_LIBADD = @MU_COMMON_LIBRARIES@
185libmailutils_la_LDFLAGS = -version-info @VI_CURRENT@:@VI_REVISION@:@VI_AGE@
186

Return to:

Send suggestions and report system problems to the System administrator.