summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2003-02-14 11:40:41 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2003-02-14 11:40:41 +0000
commit53c4cc94b181d29e51d7b1258be2ec83d1016d08 (patch)
tree5c5bdb29aa6f9a339a9e6ee5a8279cb1eac4ee91 /configure.ac
parent7255ead4619465e4398ece07ab3fd0740f03a7ea (diff)
downloadmailutils-53c4cc94b181d29e51d7b1258be2ec83d1016d08.tar.gz
mailutils-53c4cc94b181d29e51d7b1258be2ec83d1016d08.tar.bz2
New option --enable-mh-utils.
Added check for Emacs lisp directory
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 21 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 92bae824b..d19e62c55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -423,13 +423,19 @@ MU_ENABLE_SUPPORT(mh,
[BUILD_MH_PROGRAMS='$(PROGRAMS_MH)';
BUILD_MH_LIBRARIES='$(LIBRARIES_MH)'])
-AC_ARG_ENABLE([experimental],
- AC_HELP_STRING([--enable-experimental],
- [build experimental and/or unfinished utilities]),
- [MU_BUILD_EXPERIMENTAL="${enableval}"],
- [MU_BUILD_EXPERIMENTAL=no])
-
-if test ".$MU_BUILD_EXPERIMENTAL" = ".no"; then
+dnl AC_ARG_ENABLE([experimental],
+dnl AC_HELP_STRING([--enable-experimental],
+dnl [build experimental and/or unfinished utilities]),
+dnl [MU_BUILD_EXPERIMENTAL="${enableval}"],
+dnl [MU_BUILD_EXPERIMENTAL=no])
+
+AC_ARG_ENABLE([mh-utils],
+ AC_HELP_STRING([--enable-mh-utils],
+ [Build MH utilities]),
+ [MU_BUILD_MH="${enableval}"],
+ [MU_BUILD_MH=no])
+
+if test ".$MU_BUILD_MH" = ".no"; then
BUILD_MH_PROGRAMS=
BUILD_MH_LIBRARIES=
else
@@ -599,6 +605,14 @@ if test x"$useguile" = x"yes"; then
],[useguile=no])
fi
+dnl Check for Emacs site-lisp directory
+AM_PATH_LISPDIR
+
+if test "$EMACS" != "no"; then
+ lisp_LISP='$(LISPSRC)'
+fi
+AC_SUBST(lisp_LISP)
+
dnl Make sysconfdir available to the application
dnl This must be done LAST, since CPPFLAGS is passed by configure
dnl to build tests, but this relies on being run in make to

Return to:

Send suggestions and report system problems to the System administrator.