summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2003-03-03 08:19:15 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2003-03-03 08:19:15 +0000
commit485da4d61f26468b8e15ef4433433dccd508cdad (patch)
treed31eb5a7c3edc6c1a73562eaaa0c52c3d503e152 /configure.ac
parenta2ae8f79bfdce57b6e7994ed8d8b5f7464f96d3a (diff)
downloadmailutils-485da4d61f26468b8e15ef4433433dccd508cdad.tar.gz
mailutils-485da4d61f26468b8e15ef4433433dccd508cdad.tar.bz2
New option --with-included-argp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 19 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index c90ecd035..fc0268bbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,19 +337,25 @@ MU_CHECK_FUNCS(strtok_r getline strndup strnlen strchrnul)
MU_CHECK_UTMP
dnl Check for libraries
-AC_CHECK_FUNCS(argp_parse, :,
- [
- MU_LIBOBJ(argp-ba)
- MU_LIBOBJ(argp-eexst)
- MU_LIBOBJ(argp-fmtstream)
- MU_LIBOBJ(argp-fs-xinl)
- MU_LIBOBJ(argp-help)
- MU_LIBOBJ(argp-parse)
- MU_LIBOBJ(argp-pv)
- MU_LIBOBJ(argp-pvh)
- MU_LIBOBJ(argp-xinl)
- MU_LIBOBJ(pin)
- ])
+USE_INCLUDED_ARGP=
+AC_ARG_WITH([included-argp],
+ AC_HELP_STRING([--with-included-argp],
+ [Use included argp library]),
+ [USE_INCLUDED_ARGP=${withval}],
+ [AC_CHECK_FUNCS(argp_parse, :, [USE_INCLUDED_ARGP=yes])])
+
+if test $USE_INCLUDED_ARGP = yes; then
+ MU_LIBOBJ(argp-ba)
+ MU_LIBOBJ(argp-eexst)
+ MU_LIBOBJ(argp-fmtstream)
+ MU_LIBOBJ(argp-fs-xinl)
+ MU_LIBOBJ(argp-help)
+ MU_LIBOBJ(argp-parse)
+ MU_LIBOBJ(argp-pv)
+ MU_LIBOBJ(argp-pvh)
+ MU_LIBOBJ(argp-xinl)
+ MU_LIBOBJ(pin)
+fi
AC_MSG_CHECKING(whether extern program_invocation_name is present)
AC_TRY_COMPILE([#include <argp.h>

Return to:

Send suggestions and report system problems to the System administrator.