aboutsummaryrefslogtreecommitdiff
path: root/src/builtin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/builtin/Makefile.am')
-rw-r--r--src/builtin/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/src/builtin/Makefile.am b/src/builtin/Makefile.am
index 7d5db661..bf61f163 100644
--- a/src/builtin/Makefile.am
+++ b/src/builtin/Makefile.am
@@ -64,7 +64,8 @@ EXTRA_DIST = \
builtin.def\
builtin.h\
init.m4\
- snarf.m4
+ snarf.m4\
+ indent.pro
BUILT_SOURCES=\
$(BI_FILES:.bi=.c)\
@@ -87,9 +88,17 @@ SUFFIXES = .bi .c .def .h .mfi .mf
M4=m4
+if COND_GNU_INDENT
+ REINDENT = | INDENT_PROFILE=$(srcdir)/indent.pro $(INDENT)
+else
+ REINDENT =
+endif
+
.bi.c:
- $(AM_V_GEN)$(M4) --prefix -s -DSOURCE="$<" $(top_srcdir)/src/builtin/snarf.m4 $< > $@
+ $(AM_V_GEN)$(M4) --prefix -s -DSOURCE="$<" \
+ $(srcdir)/snarf.m4 $< $(REINDENT) > $@
.def.h:
- $(AM_V_GEN) $(M4) --prefix $(top_srcdir)/src/builtin/init.m4 $(BI_FILES) $< > $@
+ $(AM_V_GEN) $(M4) --prefix \
+ $(srcdir)/init.m4 $(BI_FILES) $< $(REINDENT) > $@

Return to:

Send suggestions and report system problems to the System administrator.