aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 6 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index edb71b49..7668ae06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
# This program is distributed in the hope that it will be useful,
@@ -19,7 +19,7 @@
AC_PREREQ(2.59)
m4_define([MF_VERSION_MAJOR], 4)
m4_define([MF_VERSION_MINOR], 1)
-dnl m4_define([MF_VERSION_PATCH], 0)
+m4_define([MF_VERSION_PATCH], 1)
AC_INIT([mailfromd],
MF_VERSION_MAJOR.MF_VERSION_MINOR[]m4_ifdef([MF_VERSION_PATCH],.MF_VERSION_PATCH),
[bug-mailfromd@gnu.org.ua])
@@ -122,20 +122,9 @@ AC_SUBST(lisp_LISP)
AM_GNU_GETTEXT([external], [need-formatstring-macros])
AM_GNU_GETTEXT_VERSION([0.16])
-# Syslog
-AC_ARG_ENABLE([syslog-async],
- AC_HELP_STRING([--enable-syslog-async],
- [enable non-blocking version of syslog]),
- [case "${enableval}" in
- yes) syslog_async=yes ;;
- no) syslog_async=no ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --enable-syslog-async]) ;;
- esac],[syslog_async=no])
-
-if test $syslog_async = "yes"; then
- AC_SUBST([BUILD_SYSLOG_ASYNC], 'libsyslog_async.a')
- AC_SUBST([SYSLOG_LIBS], './libsyslog_async.a')
- AC_DEFINE([USE_SYSLOG_ASYNC], [1], [Define if syslog-async is being used])
+# Syslog -- removed due to version incompatibility
+if test "${enable_syslog_async+set}" = set; then
+ AC_MSG_WARN([The option --enable-syslog-async is no longer supported.])
fi
# Check for DBM flavor
@@ -580,7 +569,7 @@ negative_dns_expire=$DEFAULT_DNS_NEGATIVE_EXPIRE_INTERVAL
rates_expire=$DEFAULT_EXPIRE_RATES_INTERVAL
usereadline=$usereadline
rendition=$RENDITION
-if test $syslog_async = "yes"; then
+if test "$syslog_async" = "yes"; then
syslog_flavor="non-blocking"
else
syslog_flavor="standard"

Return to:

Send suggestions and report system problems to the System administrator.