aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3f449a2f..2be026fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,7 +231,17 @@ AC_SUBST(MU_COMMON_INCLUDES)
check_slackware_bdb() {
dir=db`echo $1|tr -d '.'`
save_CPPFLAGS=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS -I/usr/include/$dir"
+ while test -n "$dir"
+ do
+ if test -d /usr/include/$dir; then
+ CPPFLAGS="$CPPFLAGS -I/usr/include/$dir"
+ break
+ elif test -d /usr/local/include/$dir; then
+ CPPFLAGS="$CPPFLAGS -I/usr/local/include/$dir"
+ break
+ fi
+ dir=`expr "$dir" : '\(.*\)[[0-9]]$'`
+ done
check_bdb $1 db-$1 db_create
CPPFLAGS=$save_CPPFLAGS
if test $status_dbm = "$1"; then
@@ -251,7 +261,7 @@ try_dbm() {
status_dbm=GDBM]);;
BDB2) check_bdb 2 db db_open
- test -n "$status_dbm" && status_dbm="Berkeley DB v. $status_dbm";;
+ test "$status_dbm" != "no" && status_dbm="Berkeley DB v. $status_dbm";;
BDB) for version in 4 3 2
do
@@ -283,7 +293,7 @@ try_dbm() {
done
;;
esac
- test -n "$status_dbm" && status_dbm="Berkeley DB v. $status_dbm"
+ test "$status_dbm" != "no" && status_dbm="Berkeley DB v. $status_dbm"
;;
esac
}

Return to:

Send suggestions and report system problems to the System administrator.