aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2008-03-01 01:09:16 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2008-03-01 01:09:16 +0000
commit94581b716c64295af55fd800274327e57cd8d887 (patch)
treedb5afe593071290b306945c49ac7e3ed09bde3d6 /configure.ac
parentacb622bd1cbefd11d908a764fafcd064719daf5e (diff)
downloadmailfromd-94581b716c64295af55fd800274327e57cd8d887.tar.gz
mailfromd-94581b716c64295af55fd800274327e57cd8d887.tar.bz2
* src/prog.c, src/prog.h (advance_pc): Fix type of the 2nd
argument. * configure.ac: Use AC_TRY_LINK to check for libresolve. git-svn-id: file:///svnroot/mailfromd/branches/release_4_3_patches@1619 7a8a7f39-df28-0410-adc6-e0d955640f24
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3ec336c7..aa5ae92e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,15 @@ AC_PROG_YACC
AC_PROG_LEX
# Checks for libraries.
-AC_CHECK_LIB(resolv, res_query)
+dnl Cannot use AC_CHECK_LIB to check for libresolv, because res_query
+dnl can be a macro, so resolv.h needs to be included.
+saved_LIBS=$LIBS
+LIBS="$LIBS -lresolv"
+AC_TRY_LINK([#include <resolv.h>],
+ [res_query ();],
+ [:],
+ [LIB=$saved_LIBS])
+dnl AC_CHECK_LIB(resolv, res_query)
AC_CHECK_LIB(socket, socket)
AC_CHECK_LIB(nsl, gethostbyaddr)
AC_CHECK_LIB(rt, nanosleep)

Return to:

Send suggestions and report system problems to the System administrator.