aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2007-10-23 13:02:08 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2007-10-23 13:02:08 +0000
commit9e569139583178c7e1c35147cef3fd17493a11da (patch)
tree36defb2a0547176e1ad91b8fc653f5dc687c9da9 /configure.ac
parent80c8065d88f8c0621d6b690976dc675092db6509 (diff)
downloadmailfromd-9e569139583178c7e1c35147cef3fd17493a11da.tar.gz
mailfromd-9e569139583178c7e1c35147cef3fd17493a11da.tar.bz2
Reimplement syslog-async. Thanks Simon Kelley for relicensing it under GPLv3.
git-svn-id: file:///svnroot/mailfromd/trunk@1520 7a8a7f39-df28-0410-adc6-e0d955640f24
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 19 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 885a804c..e49a654a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,8 +16,8 @@
AC_PREREQ(2.59)
m4_define([MF_VERSION_MAJOR], 4)
-m4_define([MF_VERSION_MINOR], 1)
-m4_define([MF_VERSION_PATCH], 1)
+m4_define([MF_VERSION_MINOR], 2)
+dnl m4_define([MF_VERSION_PATCH], 0)
AC_INIT([mailfromd],
MF_VERSION_MAJOR.MF_VERSION_MINOR[]m4_ifdef([MF_VERSION_PATCH],.MF_VERSION_PATCH),
[bug-mailfromd@gnu.org.ua])
@@ -124,9 +124,22 @@ AC_SUBST(lisp_LISP)
AM_GNU_GETTEXT([external], [need-formatstring-macros])
AM_GNU_GETTEXT_VERSION([0.16])
-# Syslog -- removed due to version incompatibility
-if test "${enable_syslog_async+set}" = set; then
- AC_MSG_WARN([The option --enable-syslog-async is no longer supported.])
+# Syslog
+AC_ARG_ENABLE([syslog-async],
+ AC_HELP_STRING([--enable-syslog-async],
+ [use non-blocking version of syslog by default]),
+ [case "${enableval}" in
+ yes) syslog_async=yes ;;
+ no) syslog_async=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-syslog-async]) ;;
+ esac],[syslog_async=no])
+
+AH_TEMPLATE([DEFAULT_SYSLOG_ASYNC],
+ [Define to 1 if syslog-async is being used by default])
+if test $syslog_async = "yes"; then
+ AC_DEFINE([DEFAULT_SYSLOG_ASYNC], [1])
+else
+ AC_DEFINE([DEFAULT_SYSLOG_ASYNC], [0])
fi
# Check for DBM flavor
@@ -560,7 +573,7 @@ Socket.................................... $socket
Expiration interval....................... $expire
Negative DNS answer expiration interval... $negative_dns_expire
Rates expire interval..................... $rates_expire
-Syslog implementation..................... $syslog_flavor
+Default syslog implementation............. $syslog_flavor
Readline (for mtasim)..................... $usereadline
Documentation rendition type.............. $rendition
*******************************************************************

Return to:

Send suggestions and report system problems to the System administrator.