aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2008-09-17 13:02:26 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2008-09-17 13:02:26 +0000
commita61b4ba14616998287aad030d7cb99991372c3a1 (patch)
treede56518ae3b88149758e5469c0d1676fd1f107a8 /Makefile.am
parentb9c1259f870c272b3e28610ea2e0e042676be7a7 (diff)
downloadmailfromd-a61b4ba14616998287aad030d7cb99991372c3a1.tar.gz
mailfromd-a61b4ba14616998287aad030d7cb99991372c3a1.tar.bz2
Minor fix.
* Makefile.am (dist-hook): New rule. Test for leftover FIXMEs in NEWS. git-svn-id: file:///svnroot/mailfromd/trunk@1672 7a8a7f39-df28-0410-adc6-e0d955640f24
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f2f8511b..88f709e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,15 @@ ACLOCAL_AMFLAGS = -I m4
distuninstallcheck_listfiles = find . -type f -not -name 'mailfromd.rc' -print
+dist-hook:
+ @PATCHLEV=`echo "$(PACKAGE_VERSION)" | sed -r "s/[0-9]+\.[0-9]+\.?//"`; \
+ if test $${PATCHLEV:-0} -lt 50; then \
+ if grep -q FIXME NEWS; then \
+ echo >&2 "NEWS file contains FIXMEs"; \
+ exit 1; \
+ fi; \
+ fi
+
alpha:
$(MAKE) dist distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`

Return to:

Send suggestions and report system problems to the System administrator.