aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ed125b6..db5513a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,6 +17,8 @@
bin_PROGRAMS=idest
idest_SOURCES=\
backup.c\
+ editem.c\
+ frametab.c\
guile.c\
guile.x\
idest.h\
@@ -24,7 +26,7 @@ idest_SOURCES=\
main.c\
cmdline.h\
slist.c
-BUILT_SOURCES=cmdline.h
+BUILT_SOURCES=cmdline.h frametab.c
EXTRA_DIST=cmdline.opt getopt.m4
INCLUDES=-I$(top_srcdir)/gnu -I$(top_builddir)/gnu -I$(top_srcdir)/libid3tag @GUILE_INCLUDES@
LDADD=../gnu/libgnu.a ../libid3tag/libid3tag.a -lz @GUILE_LIBS@
@@ -33,6 +35,11 @@ SUFFIXES=.opt .c .h
.opt.h:
m4 -s $(srcdir)/getopt.m4 $< | sed '1d' > $@
+GPERF_FLAGS=-tCcTnD -K id
+
+.gperf.c:
+ $(AM_V_GEN)gperf $(GPERF_FLAGS) $< > $@
+
DOT_X_FILES = guile.x
CLEANFILES=
DISTCLEANFILES=

Return to:

Send suggestions and report system problems to the System administrator.