aboutsummaryrefslogtreecommitdiff
path: root/scheme/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scheme/Makefile.am')
-rw-r--r--scheme/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/scheme/Makefile.am b/scheme/Makefile.am
new file mode 100644
index 0000000..9ca46c8
--- /dev/null
+++ b/scheme/Makefile.am
@@ -0,0 +1,35 @@
+# This file is part of Idest
+# Copyright (C) 2009-2011 Sergey Poznyakoff
+#
+# Idest is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Idest is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Idest. If not, see <http://www.gnu.org/licenses/>.
+
+EXTRA_DIST=\
+ dry-run.scm\
+ format.scm
+
+sitedir = @GUILE_SITE@/$(PACKAGE)
+
+site_DATA=\
+ dry-run.scm\
+ format.scm
+
+dist-hook:
+ tar -C $(srcdir) -c -f - --exclude-vcs idest | \
+ tar -C $(distdir) -x -f -
+
+versionsitedir = $(sitedir)/$(VERSION)
+
+install-data-local:
+ tar -c -f - idest | (cd $(DESTDIR)/$(versionsitedir); tar -x -f -)
+

Return to:

Send suggestions and report system problems to the System administrator.