aboutsummaryrefslogtreecommitdiff
path: root/libid3tag/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libid3tag/Makefile.am')
-rw-r--r--libid3tag/Makefile.am80
1 files changed, 80 insertions, 0 deletions
diff --git a/libid3tag/Makefile.am b/libid3tag/Makefile.am
new file mode 100644
index 0000000..44096eb
--- /dev/null
+++ b/libid3tag/Makefile.am
@@ -0,0 +1,80 @@
+##
+## libid3tag - ID3 tag manipulation library
+## Copyright (C) 2000-2004 Underbit Technologies, Inc.
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##
+## $Id: Makefile.am,v 1.26 2004/02/17 02:11:28 rob Exp $
+##
+
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+SUBDIRS =
+
+noinst_LIBRARIES = libid3tag.a
+noinst_HEADERS = id3tag.h
+
+EXTRA_DIST = genre.dat.sed \
+ CHANGES COPYRIGHT CREDITS README TODO VERSION
+
+if DEBUG
+debug = debug.c debug.h
+else
+debug =
+endif
+
+libid3tag_a_SOURCES = version.c ucs4.c latin1.c utf16.c utf8.c \
+ parse.c render.c field.c frametype.c compat.c \
+ genre.c frame.c crc.c util.c tag.c file.c \
+ version.h ucs4.h latin1.h utf16.h utf8.h \
+ parse.h render.h field.h frametype.h compat.h \
+ genre.h frame.h crc.h util.h tag.h file.h \
+ id3tag.h global.h genre.dat $(debug)
+
+EXTRA_libid3tag_a_SOURCES = \
+ frametype.gperf compat.gperf genre.dat.in \
+ debug.c debug.h
+
+BUILT_SOURCES = frametype.c compat.c genre.dat
+
+$(srcdir)/frametype.c: $(srcdir)/frametype.gperf Makefile.am
+ cd $(srcdir) && \
+ gperf -tCcTonD -K id -N id3_frametype_lookup -s -3 -k '*' \
+ frametype.gperf | \
+ sed -e 's/\(struct id3_frametype\);/\1/' | \
+ sed -e '/\$$''Id: /s/\$$//g' >frametype.c
+
+$(srcdir)/compat.c: $(srcdir)/compat.gperf Makefile.am
+ cd $(srcdir) && \
+ gperf -tCcTonD -K id -N id3_compat_lookup -s -3 -k '*' \
+ compat.gperf | \
+ sed -e 's/\(struct id3_compat\);/\1/' | \
+ sed -e '/\$$''Id: /s/\$$//g' >compat.c
+
+$(srcdir)/genre.dat: $(srcdir)/genre.dat.in $(srcdir)/genre.dat.sed Makefile.am
+ cd $(srcdir) && \
+ sed -n -f genre.dat.sed genre.dat.in | \
+ sed -e '/\$$''Id: /s/\$$//g' >genre.dat
+
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status --recheck
+
+again:
+ $(MAKE) clean
+ $(MAKE)
+
+.PHONY: again

Return to:

Send suggestions and report system problems to the System administrator.