aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-04-14 10:48:52 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-04-14 10:48:52 +0300
commitbd3884baa80c41154616dcabdf2b2dbbac7087de (patch)
tree52a988dba330f248ee563b520d391a641a447258 /src/Makefile.am
parent432dda4caa57295dec86bee860795bd2833dfc47 (diff)
downloadidest-bd3884baa80c41154616dcabdf2b2dbbac7087de.tar.gz
idest-bd3884baa80c41154616dcabdf2b2dbbac7087de.tar.bz2
Migrate Guile support to GINT.
* gint: Add submodule. * am/guile.m4: Remove. * Makefile.am (ACLOCAL_AMFLAGS): Look for includes in gint, instead of am. (SUBDIRS): Add gint. * bootstrap.conf: Init submodule. * configure.ac: Integrate gint. Set version number 1.1.90. * src/Makefile.am: Integrate gint. * src/guile.c (struct scheme_exec_data)<result>: Remove. (scheme_safe_exec_body): Return the result of ed->handler call, not SCM_BOOL_F. (guile_safe_exec): Use scm_c_catch instead of the deprecated scm_internal_lazy_catch. (guile_apply_main): Likewise. * NEWS: Update. * libid3tag/Makefile.am (AUTOMAKE_OPTIONS): Remove. Now set in configure.ac. Add AM_V_GEN marker to actions in all rules. * libid3tag/configure.ac (AM_INIT_AUTOMAKE): Pass options here. Use silent rules by default.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 332296e..c0f22e5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,19 +24,18 @@ idest_SOURCES=\
24 main.c\ 24 main.c\
25 cmdline.h\ 25 cmdline.h\
26 slist.c 26 slist.c
27BUILT_SOURCES=cmdline.h guile.x 27BUILT_SOURCES=cmdline.h
28EXTRA_DIST=cmdline.opt getopt.m4 28EXTRA_DIST=cmdline.opt getopt.m4
29INCLUDES=-I$(top_srcdir)/gnu -I$(top_builddir)/gnu -I$(top_srcdir)/libid3tag @GUILE_INCLUDES@ 29INCLUDES=-I$(top_srcdir)/gnu -I$(top_builddir)/gnu -I$(top_srcdir)/libid3tag @GUILE_INCLUDES@
30LDADD=../gnu/libgnu.a ../libid3tag/libid3tag.a -lz @GUILE_LIBS@ 30LDADD=../gnu/libgnu.a ../libid3tag/libid3tag.a -lz @GUILE_LIBS@
31SUFFIXES=.opt .c .h .x 31SUFFIXES=.opt .c .h
32 32
33.opt.h: 33.opt.h:
34 m4 -s $(srcdir)/getopt.m4 $< | sed '1d' > $@ 34 m4 -s $(srcdir)/getopt.m4 $< | sed '1d' > $@
35 35
36DOT_X_FILES = guile.x 36DOT_X_FILES = guile.x
37 37CLEANFILES=
38snarfcppopts = -I../ $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) 38DISTCLEANFILES=
39 39sitedir = @GUILE_SITE@/$(PACKAGE)
40.c.x: 40site_DATA=
41 guile-snarf -o $@ $< $(snarfcppopts) 41include ../gint/gint.mk
42

Return to:

Send suggestions and report system problems to the System administrator.