aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2016-11-16 15:59:16 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2016-11-17 16:58:50 +0200
commit7e8606f27404fe8da3051f90eadef4076f2f7a08 (patch)
tree1c59c67ed827eda92e32dba2955b9840cbdd4774 /src/Makefile.am
parentf55d72b20824261b5ee2fa6a87573b3f6ed2863a (diff)
downloadidest-7e8606f27404fe8da3051f90eadef4076f2f7a08.tar.gz
idest-7e8606f27404fe8da3051f90eadef4076f2f7a08.tar.bz2
Keep textual data in UTF-8 internally; provide new options for recoding
* libid3tag/tag.c (id3_tag_new): Use conservative default options. * configure.ac: Check for iconv * src/utf8conv.c: New file. * src/Makefile.am (idest_SOURCES): Add new source file. (LDADD): Link with iconv libraries. * src/backup.c (copy_file): Initialize fsize properly. * src/cmdline.opt: New options: --fixup, --broken-8bit-charset, --encoding * src/guile.c: Remove unused functions. * src/frametab.gperf: Use textual_frame_encoding. * src/idest.h: Include locale.h (latin1_option): Remove. (charset,broken_8bit_charset) (textual_frame_encoding,fixup_option): New globals. (idest_conv_mode): New enum (utf8_convert): New proto. * src/idop.c (idest_ucs4_cvt): Hanlde broken_8bit_charset option. (set_tags): Fix-up frames if so requested. * src/main.c (latin1_option): Remove. (textual_frame_encoding,fixup_option): New globals (main): Set locale. * bootstrap: Update. * gnulib: Update. * gnulib.modules: Add localcharset * doc/html.init: Minor change. * doc/idest.texi: Update docs.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2c34303..8c4c895 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of Idest
-# Copyright (C) 2009-2011 Sergey Poznyakoff
+# Copyright (C) 2009-2011, 2016 Sergey Poznyakoff
#
# Idest is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -26,7 +26,8 @@ idest_SOURCES=\
idop.c\
main.c\
cmdline.h\
- slist.c
+ slist.c\
+ utf8conv.c
BUILT_SOURCES=cmdline.h frametab.c
EXTRA_DIST=cmdline.opt getopt.m4
AM_CPPFLAGS = \
@@ -37,7 +38,8 @@ AM_CPPFLAGS = \
-I$(top_builddir)/gnu\
-I$(top_srcdir)/libid3tag\
@GUILE_INCLUDES@
-LDADD=../gnu/libgnu.a ../libid3tag/libid3tag.a -lz @GUILE_LIBS@
+
+LDADD=../gnu/libgnu.a ../libid3tag/libid3tag.a -lz @GUILE_LIBS@ @LIBICONV@
SUFFIXES=.opt .c .h
.opt.h:

Return to:

Send suggestions and report system problems to the System administrator.