aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-07-20 12:14:30 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2011-07-20 12:14:30 +0300
commit69751df3b8f70a6e62f497a8870d81d5d1e14aa4 (patch)
tree85c3f2cf2d4bb091c910cc64ddb408b26f5c3e7d /src/Makefile.am
parentb6aabc9c0877eb5c209244a93627ae232cf71d4d (diff)
downloadidest-69751df3b8f70a6e62f497a8870d81d5d1e14aa4.tar.gz
idest-69751df3b8f70a6e62f497a8870d81d5d1e14aa4.tar.bz2
Implement --format option.
* Makefile.am (SUBDIRS): Add scheme (conditionally). * configure.ac (IDEST_COND_GUILE): New condition. * examples/dry-run.scm: Move to scheme. * examples/Makefile.am: Update. * src/Makefile.am (AM_CPPFLAGS): Add VERSION_SITE. * src/cmdline.opt: New options --format and --load-path. * src/editem.c (str_split_col): Remove static qualifier. * src/guile.c (guile_add_load_path): New function. (load_startup_file): Flush user additions to the load path. Add VERSION_SITE at the beginning. * src/idest.h (list_supported_frames) (str_split_col,guile_add_load_path): New protos. * src/main.c (format_name): New global. (main): Handle --format option. * scheme/dry-run.scm: New file (from examples) * scheme/format.scm: New file. * scheme/idest/format/shortlist.scm: New file.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index db5513a..f9db6c8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -46,7 +46,8 @@ DISTCLEANFILES=
sitedir = @GUILE_SITE@/$(PACKAGE)
site_DATA=
include ../gint/gint.mk
AM_CPPFLAGS=\
-DGUILE_SITE=\"@GUILE_SITE@\"\
- -DPKG_SITE=\"$(sitedir)\" \ No newline at end of file
+ -DPKG_SITE=\"$(sitedir)\"\
+ -DVERSION_SITE=\"$(sitedir)/$(VERSION)\"

Return to:

Send suggestions and report system problems to the System administrator.