aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-02-07 16:12:03 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2009-02-07 16:12:03 +0200
commit0efd765588da43ec8cc08c5eabde49254eeb44b8 (patch)
treeae43654b9e17c2e4008af9a3520de0bc6afe1c48 /src/Makefile.am
parent9b5fb2470499d0d054e6dfab55611057d669ad76 (diff)
downloadidest-0efd765588da43ec8cc08c5eabde49254eeb44b8.tar.gz
idest-0efd765588da43ec8cc08c5eabde49254eeb44b8.tar.bz2
Implement ID3v2 read-only access.
* .gitignore: Add core. * gnulib.modules: Add argmatch and linked-list. * src/.gitignore: Add .gdbinit * src/slist.c: New file * src/Makefile.am (id3ed_SOURCES): Add new files. * src/cmdline.opt: Remove all options, except -q and --latin1. Add new options: --all and --set. * src/getopt.m4 (BEGIN): Fix handling of optional arguments. * src/id3ed.h: Include xalloc.h, gl_linked_list.h and argmatch.h (v1_block,title,artist,album,year,comment,track,genre): Remove. (DEFAULT_ED_LIST): New define. (set_id3v1): Takes 2 arguments. (string_list_action_fn): new data type. (new_string_list,do_string_list,concat_string_list) (print_string_list): New prototypes. (ed_list_add_item,ed_list_print,ed_list_add_assignment): New prototypes. * src/id3v1.c (id3v1_read,id3v1_write): Bugfixes. (set_id3v1): Take a pointer to id3v1_block as 2nd argument. * src/id3v2.c: Implement show_tags. * src/main.c: Rewrite.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c4205a8..f9d0736 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,12 @@
bin_PROGRAMS=id3ed
-id3ed_SOURCES=id3ed.h id3v1.c id3v1.h id3v2.c main.c cmdline.h
+id3ed_SOURCES=\
+ id3ed.h\
+ id3v1.c\
+ id3v1.h\
+ id3v2.c\
+ main.c\
+ cmdline.h\
+ slist.c
BUILT_SOURCES=cmdline.h
EXTRA_DIST=cmdline.opt getopt.m4
INCLUDES=-I$(top_srcdir)/gnu -I$(top_builddir)/gnu

Return to:

Send suggestions and report system problems to the System administrator.