aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-04-14 10:48:52 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-04-14 10:48:52 +0300
commitbd3884baa80c41154616dcabdf2b2dbbac7087de (patch)
tree52a988dba330f248ee563b520d391a641a447258 /configure.ac
parent432dda4caa57295dec86bee860795bd2833dfc47 (diff)
downloadidest-bd3884baa80c41154616dcabdf2b2dbbac7087de.tar.gz
idest-bd3884baa80c41154616dcabdf2b2dbbac7087de.tar.bz2
Migrate Guile support to GINT.
* gint: Add submodule. * am/guile.m4: Remove. * Makefile.am (ACLOCAL_AMFLAGS): Look for includes in gint, instead of am. (SUBDIRS): Add gint. * bootstrap.conf: Init submodule. * configure.ac: Integrate gint. Set version number 1.1.90. * src/Makefile.am: Integrate gint. * src/guile.c (struct scheme_exec_data)<result>: Remove. (scheme_safe_exec_body): Return the result of ed->handler call, not SCM_BOOL_F. (guile_safe_exec): Use scm_c_catch instead of the deprecated scm_internal_lazy_catch. (guile_apply_main): Likewise. * NEWS: Update. * libid3tag/Makefile.am (AUTOMAKE_OPTIONS): Remove. Now set in configure.ac. Add AM_V_GEN marker to actions in all rules. * libid3tag/configure.ac (AM_INIT_AUTOMAKE): Pass options here. Use silent rules by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index edd0e2b..b94671e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,12 +16,14 @@
# along with Idest. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.61)
-AC_INIT(idest, 1.1, [gray@gnu.org.ua])
+AC_INIT([idest], [1.1.90], [gray@gnu.org.ua])
AC_CONFIG_SRCDIR([src/idest.h])
AC_CONFIG_HEADER([config.h])
AC_CONFIG_AUX_DIR([build-aux])
-AM_INIT_AUTOMAKE([1.9 gnits tar-ustar std-options])
-
+AM_INIT_AUTOMAKE([1.9 gnits tar-ustar std-options silent-rules])
+# Enable silent rules by default:
+AM_SILENT_RULES([yes])
+
# Checks for programs.
AC_PROG_CC
gl_EARLY
@@ -48,7 +50,9 @@ AC_ARG_WITH([guile],
[status_guile=yes])
if test $status_guile = yes; then
- IDEST_CHECK_GUILE(1.8)
+ GINT_INIT([gint],[1.8 nodoc],
+ [status_guile=yes],
+ [status_guile=no])
fi
AC_CONFIG_SUBDIRS(libid3tag)
@@ -68,6 +72,7 @@ EOF
AC_CONFIG_FILES([Makefile
gnu/Makefile
+ gint/Makefile
src/Makefile
doc/Makefile])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.