aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2005-09-03 14:14:24 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2005-09-03 14:14:24 +0000
commitcdc8832cf9b18e82c463f9bfae5ca81f77d194f1 (patch)
tree1bc1aa5b34ee77cd82c56c3bb611e5b9e94a7cac /configure.ac
parentdf5327e84663a3a08b414f30cafeff8f27eb447f (diff)
downloadgsc-cdc8832cf9b18e82c463f9bfae5ca81f77d194f1.tar.gz
gsc-cdc8832cf9b18e82c463f9bfae5ca81f77d194f1.tar.bz2
Added configuration framework
git-svn-id: file:///svnroot/gsc/trunk@104 d2de0444-eb31-0410-8365-af798a554d48
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac96
1 files changed, 96 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..ca5129f
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,96 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT([gsc], 1.0, [gray@gnu.org.ua])
+AC_CONFIG_SRCDIR([cvs/sv_sync_www.c])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_LEX
+AC_PROG_YACC
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_UID_T
+AC_FUNC_OBSTACK
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+AC_HEADER_STDBOOL
+
+# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_FORK
+AC_FUNC_MALLOC
+AC_FUNC_MEMCMP
+AC_FUNC_STAT
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS([memset strchr strdup strerror strrchr])
+
+# Sendmail version or cfdir
+AC_SUBST(SENDMAIL_VERSION)
+AC_ARG_WITH([sendmail-version],
+ [AC_HELP_STRING([--with-sendmail-version=VERSION],
+ [Build .cf files for given Sendmail version])],
+ [SENDMAIL_VERSION=$withval],
+ [SENDMAIL_VERSION=])
+
+AC_SUBST(SENDMAIL_CFDIR)
+AC_ARG_WITH([sendmail-cfdir],
+ [AC_HELP_STRING([--with-sendmail-cfdir=DIR],
+ [Specify full name of Sendmail cf directory (e.g.: /usr/src/sendmail-8.13.1/cf/cf). Overrides --with-sendmail-version])],
+ [SENDMAIL_CFDIR=$withval],
+ [SENDMAIL_CFDIR=])
+
+
+
+# Check for Emacs site-lisp directory
+AM_PATH_LISPDIR
+
+if test "$EMACS" != "no"; then
+ lisp_LISP='$(LISPSRC)'
+fi
+AC_SUBST(lisp_LISP)
+
+# Consoleconf variables
+AC_SUBST(CONSOLECONFDIR)
+CONSOLECONFDIR='${datadir}/consoleconf'
+AC_SUBST(CONSOLEFONTSDIR)
+CONSOLEFONTSDIR=/usr/share/kbd/consolefonts
+AC_SUBST(CONSOLETRANSDIR)
+CONSOLETRANSDIR=/usr/share/kbd/consoletrans
+
+AC_CONFIG_FILES([Makefile
+ aspell/Makefile
+ bind/Makefile
+ bind/master/Makefile
+ bind/master/bin/Makefile
+ bind/slave/Makefile
+ bind/slave/bin/Makefile
+ ckaliases/Makefile
+ consoleconf/Makefile
+ consoleconf/bin/Makefile
+ consoleconf/data/Makefile
+ consoleconf/data/motd/Makefile
+ cvs/Makefile
+ doc/Makefile
+ etc/Makefile
+ elisp/Makefile
+ firewall/Makefile
+ fixnamespace/Makefile
+ fsf-move/Makefile
+ mc/Makefile
+ ppp/Makefile
+ rc.d/Makefile])
+
+AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.