aboutsummaryrefslogtreecommitdiff
path: root/include/grecs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/grecs/Makefile.am')
-rw-r--r--include/grecs/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/include/grecs/Makefile.am b/include/grecs/Makefile.am
new file mode 100644
index 0000000..c239c1b
--- /dev/null
+++ b/include/grecs/Makefile.am
@@ -0,0 +1,43 @@
+GRECS_PKG_HDR =\
+ doc.h\
+ error.h\
+ format.h\
+ lex.h\
+ list.h\
+ locus.h\
+ mem.h\
+ node.h\
+ opt.h\
+ parser.h\
+ preproc.h\
+ sockaddr.h\
+ symtab.h\
+ table.h\
+ tree.h\
+ txtacc.h\
+ types.h\
+ util.h\
+ value.h\
+ version.h
+
+if GRECS_COND_JSON
+ GRECS_PKG_HDR += json.h
+endif
+
+if GRECS_COND_BUILD_INSTALL
+ grecsincludedir = @GRECS_INCLUDE_DIR@
+ grecsinclude_HEADERS = $(GRECS_PKG_HDR)
+endif
+
+if GRECS_COND_BUILD_SHARED
+ if GRECS_COND_INSTALLHEADERS
+ grecsincludedir = @GRECS_INCLUDE_DIR@
+ grecsinclude_HEADERS = $(GRECS_PKG_HDR)
+ else
+ noinst_HEADERS = $(GRECS_PKG_HDR)
+ endif
+endif
+
+if GRECS_COND_BUILD_STATIC
+ noinst_HEADERS = $(GRECS_PKG_HDR)
+endif

Return to:

Send suggestions and report system problems to the System administrator.