aboutsummaryrefslogtreecommitdiff
path: root/include/argot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/argot/Makefile.am')
-rw-r--r--include/argot/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/include/argot/Makefile.am b/include/argot/Makefile.am
new file mode 100644
index 0000000..9fb3fa1
--- /dev/null
+++ b/include/argot/Makefile.am
@@ -0,0 +1,43 @@
+ARGOT_PKG_HDR =\
+ doc.h\
+ error.h\
+ format.h\
+ lex.h\
+ list.h\
+ locus.h\
+ mem.h\
+ node.h\
+ opt.h\
+ parser.h\
+ preproc.h\
+ sockaddr.h\
+ symtab.h\
+ table.h\
+ tree.h\
+ txtacc.h\
+ types.h\
+ util.h\
+ value.h\
+ version.h
+
+if ARGOT_COND_JSON
+ ARGOT_PKG_HDR += json.h
+endif
+
+if ARGOT_COND_BUILD_INSTALL
+ argotincludedir = @ARGOT_INCLUDE_DIR@
+ argotinclude_HEADERS = $(ARGOT_PKG_HDR)
+endif
+
+if ARGOT_COND_BUILD_SHARED
+if ARGOT_COND_INSTALLHEADERS
+ argotincludedir = @ARGOT_INCLUDE_DIR@
+ argotinclude_HEADERS = $(ARGOT_PKG_HDR)
+else
+ noinst_HEADERS = $(ARGOT_PKG_HDR)
+endif
+endif
+
+if ARGOT_COND_BUILD_STATIC
+ noinst_HEADERS = $(ARGOT_PKG_HDR)
+endif

Return to:

Send suggestions and report system problems to the System administrator.