aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-05-19 00:43:33 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2011-05-19 00:43:33 +0300
commit6ef143bd53c35635b6d7edc6410d45fa58f54da2 (patch)
treebb53c4652d46b532b1d86db4b258edfecd90e18c /Makefile.am
parent9388982950195420a96db58f04a5e6d0f292559e (diff)
downloadgrecs-6ef143bd53c35635b6d7edc6410d45fa58f54da2.tar.gz
grecs-6ef143bd53c35635b6d7edc6410d45fa58f54da2.tar.bz2
Bugfixes.
* Makefile.am: Fix format to git log. * src/bind-lex.l (grecs_bind_close_sources): Reset input_stack to 0. * src/lookup.c (split_cfg_path): Allow only one of "./:;,^~" at the beginning of a path.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0696c72..339b1be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,7 @@ gitid.h:
if test "$$url" = "git.gnu.org.ua/grecs.git"; then \
dirty=`git diff-index --name-only HEAD 2>/dev/null` || dirty=;\
test -n "$$dirty" && dirty="-dirty"; \
- ID=`git log -1 --pretty='%H-%ct-%ae'`$$dirty;\
+ ID=`git log -1 --pretty='format:%H-%ct-%ae'`$$dirty;\
echo "#define GRECS_GIT_ID \"$$ID\"" > gitid.tmp; \
cmp gitid.tmp gitid.h >/dev/null 2>&1 || mv gitid.tmp gitid.h; \
rm -f gitid.tmp; \

Return to:

Send suggestions and report system problems to the System administrator.