aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-05-10 14:22:28 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2011-05-10 14:22:28 +0300
commit3e5d6e9683d5d3efa3a82556d0f73892d674ed71 (patch)
tree0baa7d3cecce3b984e85eef238887d501b780744 /Makefile.am
parent8bd6f1e59b1663089bf8c81d8d2b14e20010c6e4 (diff)
downloadgrecs-3e5d6e9683d5d3efa3a82556d0f73892d674ed71.tar.gz
grecs-3e5d6e9683d5d3efa3a82556d0f73892d674ed71.tar.bz2
Bugfixes.
* Makefile.am (gitid.h): Fix sed expression. * src/grecs.h (grecs_hash_string): New proto. * src/symtab.c (grecs_hash_string): New function.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 46c5c46..d614a25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,8 +24,8 @@ BUILT_SOURCES = gitid.h README
.PHONY: gitid.h
gitid.h:
@if test -d .git; then \
- url=`git config --get remote.origin.url | sed 's|.*://||'`; \
- if test "$$url" = "git.gnu.org.ua/gitroot/grecs.git"; then \
+ url=`git config --get remote.origin.url | sed 's|.*://||;s|/gitroot/|/|'`; \
+ if test "$$url" = "git.gnu.org.ua/grecs.git"; then \
dirty=`git diff-index --name-only HEAD 2>/dev/null` || dirty=;\
test -n "$$dirty" && dirty="-dirty"; \
ID=`git log -1 --pretty='%H-%ct-%ae'`$$dirty;\

Return to:

Send suggestions and report system problems to the System administrator.