aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..764cddc
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([genrc], [0.1], [gray@gnu.org])
+AC_CONFIG_SRCDIR([src/genrc.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([1.11 foreign silent-rules])
+AC_CONFIG_MACRO_DIR(grecs/am)
+
+# Enable silent rules by default
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+
+# Checks for libraries.
+AC_CHECK_LIB(pcre, main)
+
+# Checks for header files.
+AC_CHECK_HEADERS([getopt.h pcre.h])
+
+# Checks for library functions.
+AC_CHECK_FUNCS([getdtablesize])
+
+GRECS_SETUP(grecs, [all-parsers git2chg])
+
+AM_CONDITIONAL([COND_PCRE],
+ [test "$ac_cv_header_pcre_h" = yes && test "$ac_cv_lib_pcre_main" = yes])
+
+AC_CONFIG_FILES([Makefile
+ src/Makefile])
+
+AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.