aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a7c97e1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
1ACLOCAL_AMFLAGS = -I m4
2SUBDIRS = gdbm/master gdbm/newcache src
3BENCHMARKDIR=benchmarks
4benchmark:
5 @if test -z "$(NRECS)"; then \
6 echo "Please set NRECS"; \
7 exit 1; \
8 fi; \
9 if test -z "$(NKEYS)"; then \
10 echo "Please set NKEYS"; \
11 exit 1; \
12 fi; \
13 DIRNAME="$(BENCHMARKDIR)/$(NRECS)-$(NKEYS)"; \
14 if ! test -d "$$DIRNAME"; then \
15 mkdir -p $$DIRNAME; \
16 (echo "NRECS=$(NRECS)"; \
17 echo "NKEYS=$(NKEYS)"; \
18 echo "MAXCACHE=$(MAXCACHE)"; \
19 echo "include @abs_top_builddir@/src/benchmark.mk") > $$DIRNAME/Makefile; \
20 fi; \
21 $(MAKE) -C $$DIRNAME
22

Return to:

Send suggestions and report system problems to the System administrator.