aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2020-03-14 12:02:33 +0200
committerSergey Poznyakoff <gray@gnu.org>2020-03-15 09:27:25 +0200
commit87279b57516dfd891ef03858dac1d644df758b4c (patch)
treecd45ffc5d34e94749a77987975555996c22188c9 /Makefile.am
downloadcache-benchmarks-87279b57516dfd891ef03858dac1d644df758b4c.tar.gz
cache-benchmarks-87279b57516dfd891ef03858dac1d644df758b4c.tar.bz2
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a7c97e1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+ACLOCAL_AMFLAGS = -I m4
+SUBDIRS = gdbm/master gdbm/newcache src
+BENCHMARKDIR=benchmarks
+benchmark:
+ @if test -z "$(NRECS)"; then \
+ echo "Please set NRECS"; \
+ exit 1; \
+ fi; \
+ if test -z "$(NKEYS)"; then \
+ echo "Please set NKEYS"; \
+ exit 1; \
+ fi; \
+ DIRNAME="$(BENCHMARKDIR)/$(NRECS)-$(NKEYS)"; \
+ if ! test -d "$$DIRNAME"; then \
+ mkdir -p $$DIRNAME; \
+ (echo "NRECS=$(NRECS)"; \
+ echo "NKEYS=$(NKEYS)"; \
+ echo "MAXCACHE=$(MAXCACHE)"; \
+ echo "include @abs_top_builddir@/src/benchmark.mk") > $$DIRNAME/Makefile; \
+ fi; \
+ $(MAKE) -C $$DIRNAME
+

Return to:

Send suggestions and report system problems to the System administrator.