aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..2a44d3e
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,20 @@
1use ExtUtils::MakeMaker;
2use ExtUtils::Constant 0.11 'WriteConstants';
3WriteMakefile(
4 NAME => 'GDBM_File',
5 LIBS => ["-lgdbm", "-ldbm"],
6 XSPROTOARG => '-noprototypes', # XXX remove later?
7 VERSION_FROM => 'GDBM_File.pm',
8 realclean => {FILES=> 'const-c.inc const-xs.inc'},
9 XS_VERSION => eval MM->parse_version('GDBM_File.pm'), #silence warnings if we are a dev release
10);
11WriteConstants(
12 NAME => 'GDBM_File',
13 DEFAULT_TYPE => 'IV',
14 BREAKOUT_AT => 8,
15 PROXYSUBS => {autoload => 1},
16 NAMES => [qw(GDBM_CACHESIZE GDBM_CENTFREE GDBM_COALESCEBLKS
17 GDBM_FAST GDBM_FASTMODE GDBM_INSERT GDBM_NEWDB GDBM_NOLOCK
18 GDBM_OPENMASK GDBM_READER GDBM_REPLACE GDBM_SYNC GDBM_SYNCMODE
19 GDBM_WRCREAT GDBM_WRITER)],
20);

Return to:

Send suggestions and report system problems to the System administrator.