aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1424ea0..da5b938 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,15 +173,46 @@ fi
AM_CONDITIONAL([GDBM_COND_READLINE], [test "$status_readline" = "yes"])
+# Additional debugging
+AC_ARG_ENABLE([debug],
+ AC_HELP_STRING([--enable-debug],
+ [provide additional debugging functions]),
+ [status_debug=$withval],
+ [status_debug=no])
+
+AM_CONDITIONAL([GDBM_COND_DEBUG_ENABLE], [test "$status_debug" = "yes"])
+
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
AC_CONFIG_FILES([tests/Makefile tests/atlocal po/Makefile.in])
AM_MISSING_PROG([AUTOM4TE], [autom4te])
+AC_CONFIG_COMMANDS([status],[
+cat <<EOF
+
+*******************************************************************
+GDBM settings summary:
+
+Compatibility library ......................... $status_compat
+Compatibility export tool ..................... $status_export
+Memory mapped I/O ............................. $mapped_io
+GNU Readline .................................. $status_readline
+Debugging functions ........................... $status_debug
+*******************************************************************
+
+EOF
+],
+[status_compat=$want_compat
+status_export=$want_export
+mapped_io=$mapped_io
+status_readline=$status_readline
+status_debug=$status_debug])
+
AC_CONFIG_FILES([Makefile
src/Makefile
src/gdbm.h
doc/Makefile
compat/Makefile
export/Makefile])
+
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.