aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 2 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index 3511f0d..25c4ff4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,3 +19,3 @@ m4_define([_GDBM_VERSION_MAJOR], 1)
m4_define([_GDBM_VERSION_MINOR], 14)
-m4_define([_GDBM_VERSION_PATCH], 1)
+m4_define([_GDBM_VERSION_PATCH], 90)
@@ -55,30 +55,2 @@ test -z "$COMPATINCLUDEDIR" && COMPATINCLUDEDIR='$(includedir)'
-AC_ARG_ENABLE([gdbm-export],
- AC_HELP_STRING(
- [--enable-gdbm-export],
- [Build and install gdbmexport with specified gdbm 1.8 library. (Default is NO.)]),
- [want_export=$enableval],
- [want_export=no])
-
-AC_ARG_WITH([gdbm183-library],
- AC_HELP_STRING(
- [--with-gdbm183-library],
- [Build gdbmexport with specified (static) library.]),
- [GDBM183_LIBRARY=$withval],
- [GDBM183_LIBRARY="-lgdbm"])
-
-AC_ARG_WITH([gdbm183-libdir],
- AC_HELP_STRING(
- [--with-gdbm183-libdir],
- [Build gdbmexport with the gdbm library in the specified directory.]),
- [GDBM183_LIBDIR=$withval],
- [GDBM183_LIBDIR="/usr/local/lib"])
-
-AC_ARG_WITH([gdbm183-includedir],
- AC_HELP_STRING(
- [--with-gdbm183-includedir],
- [Build gdbmexport with gdbm.h in the specified directory.]),
- [GDBM183_INCLUDEDIR=$withval],
- [GDBM183_INCLUDEDIR="/usr/local/include"])
-
dnl Check for programs
@@ -134,7 +106,3 @@ AC_CHECK_MEMBERS([struct stat.st_blksize])
-AC_SUBST(GDBM183_LIBRARY)
-AC_SUBST(GDBM183_LIBDIR)
-AC_SUBST(GDBM183_INCLUDEDIR)
AM_CONDITIONAL([COMPAT_OPT], [test "$want_compat" = yes])
-AM_CONDITIONAL([ENABLE_EXPORT], [test "$want_export" = yes])
@@ -216,3 +184,2 @@ GDBM settings summary:
Compatibility library ......................... $status_compat
-Compatibility export tool ..................... $status_export
Memory mapped I/O ............................. $mapped_io
@@ -225,3 +192,2 @@ EOF
[status_compat=$want_compat
-status_export=$want_export
mapped_io=$mapped_io
@@ -234,4 +200,3 @@ AC_CONFIG_FILES([Makefile
doc/Makefile
- compat/Makefile
- export/Makefile])
+ compat/Makefile])

Return to:

Send suggestions and report system problems to the System administrator.