aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 2 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index 3511f0d..25c4ff4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,13 +14,13 @@
#
# You should have received a copy of the GNU General Public License
# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
m4_define([_GDBM_VERSION_MAJOR], 1)
m4_define([_GDBM_VERSION_MINOR], 14)
-m4_define([_GDBM_VERSION_PATCH], 1)
+m4_define([_GDBM_VERSION_PATCH], 90)
AC_INIT([gdbm],
_GDBM_VERSION_MAJOR._GDBM_VERSION_MINOR[]m4_ifdef([_GDBM_VERSION_PATCH],._GDBM_VERSION_PATCH),
[bug-gdbm@gnu.org],,
[http://www.gnu.org/software/gdbm])
AC_PREREQ(2.69)
@@ -50,40 +50,12 @@ AC_ARG_ENABLE([libgdbm-compat],
[Build and install libgdbm_compat. (Default is NO.)]),
[want_compat=$enableval],
[want_compat=no])
AC_ARG_VAR([COMPATINCLUDEDIR],[installation directory for dbm.h and ndbm.h])
test -z "$COMPATINCLUDEDIR" && COMPATINCLUDEDIR='$(includedir)'
-AC_ARG_ENABLE([gdbm-export],
- AC_HELP_STRING(
- [--enable-gdbm-export],
- [Build and install gdbmexport with specified gdbm 1.8 library. (Default is NO.)]),
- [want_export=$enableval],
- [want_export=no])
-
-AC_ARG_WITH([gdbm183-library],
- AC_HELP_STRING(
- [--with-gdbm183-library],
- [Build gdbmexport with specified (static) library.]),
- [GDBM183_LIBRARY=$withval],
- [GDBM183_LIBRARY="-lgdbm"])
-
-AC_ARG_WITH([gdbm183-libdir],
- AC_HELP_STRING(
- [--with-gdbm183-libdir],
- [Build gdbmexport with the gdbm library in the specified directory.]),
- [GDBM183_LIBDIR=$withval],
- [GDBM183_LIBDIR="/usr/local/lib"])
-
-AC_ARG_WITH([gdbm183-includedir],
- AC_HELP_STRING(
- [--with-gdbm183-includedir],
- [Build gdbmexport with gdbm.h in the specified directory.]),
- [GDBM183_INCLUDEDIR=$withval],
- [GDBM183_INCLUDEDIR="/usr/local/include"])
-
dnl Check for programs
AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LIBTOOL
AC_PROG_YACC
@@ -129,17 +101,13 @@ then
AC_CHECK_FUNCS([msync])
fi
AC_TYPE_OFF_T
AC_CHECK_SIZEOF(off_t)
AC_CHECK_MEMBERS([struct stat.st_blksize])
-AC_SUBST(GDBM183_LIBRARY)
-AC_SUBST(GDBM183_LIBDIR)
-AC_SUBST(GDBM183_INCLUDEDIR)
AM_CONDITIONAL([COMPAT_OPT], [test "$want_compat" = yes])
-AM_CONDITIONAL([ENABLE_EXPORT], [test "$want_export" = yes])
# Check for Curses libs.
for lib in ncurses curses termcap
do
AC_CHECK_LIB($lib, tputs, [CURSES_LIBS="-l$lib"; break])
done
@@ -211,28 +179,25 @@ AC_CONFIG_COMMANDS([status],[
cat <<EOF
*******************************************************************
GDBM settings summary:
Compatibility library ......................... $status_compat
-Compatibility export tool ..................... $status_export
Memory mapped I/O ............................. $mapped_io
GNU Readline .................................. $status_readline
Debugging support ............................. $status_debug
*******************************************************************
EOF
],
[status_compat=$want_compat
-status_export=$want_export
mapped_io=$mapped_io
status_readline=$status_readline
status_debug=$status_debug])
AC_CONFIG_FILES([Makefile
src/Makefile
src/gdbm.h
doc/Makefile
- compat/Makefile
- export/Makefile])
+ compat/Makefile])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.