aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e00dec..ecc03df 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,29 +15,43 @@
15# You should have received a copy of the GNU General Public License 15# You should have received a copy of the GNU General Public License
16# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */ 16# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
17 17
18EXTRA_DIST = build-aux/config.rpath NOTE-WARNING git2chg.awk 18EXTRA_DIST = build-aux/config.rpath NOTE-WARNING git2chg.awk
19 19
20if COMPAT_OPT 20if COMPAT_OPT
21 MAYBE_COMPAT = compat 21 MAYBE_COMPAT = compat
22endif 22endif
23SUBDIRS = po src doc $(MAYBE_COMPAT) tests 23SUBDIRS = po src doc $(MAYBE_COMPAT) tests
24 24
25AM_DISTCHECK_CONFIGURE_FLAGS = --enable-libgdbm-compat 25AM_DISTCHECK_CONFIGURE_FLAGS = --enable-libgdbm-compat
26 26
27dist-hook: 27.PHONY: set-dist-date
28set-dist-date:
28 rm -f $(distdir)/src/version.c; \ 29 rm -f $(distdir)/src/version.c; \
29 d=`date '+%d/%m/%Y'`; \ 30 d=`date '+%d/%m/%Y'`; \
30 sed 's|/\*@DIST_DATE@\*/|"'"$$d"'"|' $(srcdir)/src/version.c > \ 31 sed 's|/\*@DIST_DATE@\*/|"'"$$d"'"|' $(srcdir)/src/version.c > \
31 $(distdir)/src/version.c 32 $(distdir)/src/version.c
32 33
34dist-hook: ChangeLog set-dist-date
35 @if test -f ChangeLog && test -f NEWS; then \
36 PATCHLEV=`echo "$(PACKAGE_VERSION)" | sed -r "s/[0-9]+\.[0-9]+\.?//"`;\
37 if test $${PATCHLEV:-0} -lt 50; then \
38 if grep -q FIXME NEWS; then \
39 echo >&2 "*** NEWS file contains FIXMEs"; \
40 echo >&2 "*** Aborting"; \
41 exit 1; \
42 fi; \
43 fi; \
44 fi
45
46
33gen_start_date = 2016-07-08 47gen_start_date = 2016-07-08
34prev_change_log = ChangeLog.cvs 48prev_change_log = ChangeLog.cvs
35 49
36.PHONY: ChangeLog 50.PHONY: ChangeLog
37ChangeLog: 51ChangeLog:
38 $(AM_V_GEN)if test -d .git; then \ 52 $(AM_V_GEN)if test -d .git; then \
39 git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' \ 53 git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' \
40 --since=$(gen_start_date) | \ 54 --since=$(gen_start_date) | \
41 awk -f $(top_srcdir)/git2chg.awk \ 55 awk -f $(top_srcdir)/git2chg.awk \
42 -v append=$(top_srcdir)/$(prev_change_log) > ChangeLog; \ 56 -v append=$(top_srcdir)/$(prev_change_log) > ChangeLog; \
43 fi 57 fi

Return to:

Send suggestions and report system problems to the System administrator.