aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e00dec..ecc03df 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,12 +24,26 @@ SUBDIRS = po src doc $(MAYBE_COMPAT) tests
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-libgdbm-compat
-dist-hook:
+.PHONY: set-dist-date
+set-dist-date:
rm -f $(distdir)/src/version.c; \
d=`date '+%d/%m/%Y'`; \
sed 's|/\*@DIST_DATE@\*/|"'"$$d"'"|' $(srcdir)/src/version.c > \
$(distdir)/src/version.c
+dist-hook: ChangeLog set-dist-date
+ @if test -f ChangeLog && test -f NEWS; then \
+ PATCHLEV=`echo "$(PACKAGE_VERSION)" | sed -r "s/[0-9]+\.[0-9]+\.?//"`;\
+ if test $${PATCHLEV:-0} -lt 50; then \
+ if grep -q FIXME NEWS; then \
+ echo >&2 "*** NEWS file contains FIXMEs"; \
+ echo >&2 "*** Aborting"; \
+ exit 1; \
+ fi; \
+ fi; \
+ fi
+
+
gen_start_date = 2016-07-08
prev_change_log = ChangeLog.cvs

Return to:

Send suggestions and report system problems to the System administrator.