aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 17 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 5356c17..957e87a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,5 @@
# This file is part of GDBM. -*- Makefile -*-
-# Copyright (C) 2007, 2011, 2013, 2016-2019 Free Software Foundation,
-# Inc.
+# Copyright (C) 2007-2023 Free Software Foundation, Inc.
#
# GDBM is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -15,12 +14,12 @@
# You should have received a copy of the GNU General Public License
# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
-EXTRA_DIST = build-aux/config.rpath NOTE-WARNING git2chg.awk
+EXTRA_DIST = build-aux/config.rpath NOTE-WARNING
if COMPAT_OPT
MAYBE_COMPAT = compat
endif
-SUBDIRS = po src doc $(MAYBE_COMPAT) tests
+SUBDIRS = po src tools doc $(MAYBE_COMPAT) tests
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-libgdbm-compat
@@ -50,8 +49,18 @@ prev_change_log = ChangeLog.cvs
.PHONY: ChangeLog
ChangeLog:
$(AM_V_GEN)if test -d .git; then \
- git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' \
- --since=$(gen_start_date) | \
- awk -f $(top_srcdir)/git2chg.awk \
- -v append=$(top_srcdir)/$(prev_change_log) > ChangeLog; \
+ (git log --pretty='format:%ad %cn <%ae>%n%n%w(72,8,8)%s%n%n%b' \
+ --date=short \
+ --since=$(gen_start_date); \
+ echo ""; \
+ cat $(prev_change_log); \
+ echo ""; \
+ echo "Local Variables:"; \
+ echo "mode: change-log"; \
+ echo "version-control: never"; \
+ echo "buffer-read-only: t"; \
+ echo "End:") > ChangeLog.tmp; \
+ cmp ChangeLog ChangeLog.tmp > /dev/null 2>&1 || \
+ mv ChangeLog.tmp ChangeLog; \
+ rm -f ChangeLog.tmp; \
fi

Return to:

Send suggestions and report system problems to the System administrator.