aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-05-13 16:46:30 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2013-05-13 16:46:30 +0000
commitaa0eaa5bc642167db8cfb5778cf9a0091401a4f3 (patch)
treea5a6cbdc9ca61b6867bd902fc880efd2eaa0f29c /src/Makefile.am
parent1638ed6202b77b521214128189dc4aacdb5fe098 (diff)
downloadgdbm-aa0eaa5bc642167db8cfb5778cf9a0091401a4f3.tar.gz
gdbm-aa0eaa5bc642167db8cfb5778cf9a0091401a4f3.tar.bz2
Implement shell variables in gdbmtool.
* src/var.c: New file. * src/datconv.c (datum_format): Remove the "delim" parameter, use "delim1" and "delim2" shell variables instead. * src/gdbmtool.c: Remove "prompt" command. Use "set ps[12]" instead. (print_prompt): Move to lex.l * src/gdbmtool.h (variable_set) (variable_get, variable_print_all): New protos. * src/gram.y: Handle the "set" command. * src/lex.l: Update.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 795832d..832fd55 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -84,7 +84,8 @@ gdbmtool_SOURCES = \
gram.y\
lex.l\
gdbmtool.h\
- gdbmtool.c
+ gdbmtool.c\
+ var.c
AM_YFLAGS = -dtv
#AM_LFLAGS = -d

Return to:

Send suggestions and report system problems to the System administrator.