aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2017-12-23 22:51:42 +0200
committerSergey Poznyakoff <gray@gnu.org>2017-12-23 22:51:42 +0200
commitebc76f93985365d33c789c202b523e6b859e85b6 (patch)
tree9c5eb3376e0a018d7fd9bdbf4a9669772e65a717 /configure.ac
parent2e8a5e0be7b2db179018c10248a6cc64f9db3314 (diff)
downloadgdbm-ebc76f93985365d33c789c202b523e6b859e85b6.tar.gz
gdbm-ebc76f93985365d33c789c202b523e6b859e85b6.tar.bz2
Complement c175231e
* configure.ac: Check whether __thread qualifier is supported * src/gdbmerrno.c (gdbm_errno_storage): Use GDBM_THREAD_LOCAL instead of __thread.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 944fa7c..f172f8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,13 +14,13 @@
#
# You should have received a copy of the GNU General Public License
# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
m4_define([_GDBM_VERSION_MAJOR], 1)
m4_define([_GDBM_VERSION_MINOR], 13)
-dnl m4_define([_GDBM_VERSION_PATCH], 90)
+m4_define([_GDBM_VERSION_PATCH], 90)
AC_INIT([gdbm],
_GDBM_VERSION_MAJOR._GDBM_VERSION_MINOR[]m4_ifdef([_GDBM_VERSION_PATCH],._GDBM_VERSION_PATCH),
[bug-gdbm@gnu.org],,
[http://www.gnu.org/software/gdbm])
AC_PREREQ(2.69)
@@ -96,12 +96,20 @@ AC_SUBST(GDBM_COUNT_T)
if test $ac_cv_type_unsigned_long_long_int = yes; then
GDBM_COUNT_T="unsigned long long int"
else
GDBM_COUNT_T="unsigned long"
fi
+AC_MSG_CHECKING([for TLS qualifier])
+AC_TRY_COMPILE([],
+ [static __thread int x = 0;],
+ [gdbm_cv__thread=__thread],
+ [gdbm_cv__thread=])
+AC_MSG_RESULT($gdbm_cv__thread)
+AC_DEFINE_UNQUOTED([GDBM_THREAD_LOCAL],$gdbm_cv__thread,[TLS qualifier])
+
dnl Internationalization macros.
AM_GNU_GETTEXT([external], [need-ngettext])
AM_GNU_GETTEXT_VERSION(0.18)
AC_CHECK_HEADERS([sys/file.h sys/termios.h string.h locale.h getopt.h])

Return to:

Send suggestions and report system problems to the System administrator.