aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Downs <downsj@downsj.com>2008-11-30 05:31:02 +0000
committerJason Downs <downsj@downsj.com>2008-11-30 05:31:02 +0000
commitda266015729fb8cf7519813c222fb83154ca0b8a (patch)
treeb30210adbb7a0d17d727d7a4bfa7ae0526120ddd /configure.ac
parent10fe387708ddfba6449b9abd74cfbdf67d495465 (diff)
downloadgdbm-da266015729fb8cf7519813c222fb83154ca0b8a.tar.gz
gdbm-da266015729fb8cf7519813c222fb83154ca0b8a.tar.bz2
The library was not working on Solaris due to file locking. fcntl locks are
not working over NFS at all. They also need to be changed to use flock64 structs, which has been done. File locking needs to be refactored within the library. We likely need to add lockf support, and use a better method for determining which locking type to use (our current method is to just make assumptions). testgdbm now builds on Solaris. From ChangeLog: * configure.ac: Add test for sys/termios.h * src/systems.h: Add macros for Solaris-style 64bit fcntl locks. * src/testgdbm.c: Add support for opening files without locking. Add sys/termios.h include and add check for TIOCWINSZ. * export/export.c: Add support for opening files without locking.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c4bc2d..453b150 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,3 +67,3 @@ AC_C_CONST
-AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h fcntl.h sys/types.h memory.h])
+AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h fcntl.h sys/types.h memory.h sys/termios.h])

Return to:

Send suggestions and report system problems to the System administrator.