aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-08-03 14:34:53 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2011-08-03 14:34:53 +0000
commit5578723a05d79de57c4918c09f5c9b47c764ace7 (patch)
treee093f4af6af5374353b39d6f3db17a86ce759d72 /configure.ac
parent08f5082e136af01d94e301e74a24b04e41193b6f (diff)
downloadgdbm-5578723a05d79de57c4918c09f5c9b47c764ace7.tar.gz
gdbm-5578723a05d79de57c4918c09f5c9b47c764ace7.tar.bz2
Define Major,Minor numbers and Patchlevel separately.
(GDBM_VERSION_MAJOR,GDBM_VERSION_MINOR) (GDBM_VERSION_PATCH): New substitution variables.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3e7f09e..4dac1ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,20 +11,30 @@
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the 11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12# GNU General Public License for more details. 12# GNU General Public License for more details.
13# 13#
14# You should have received a copy of the GNU General Public License 14# You should have received a copy of the GNU General Public License
15# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */ 15# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
16 16
17AC_INIT([gdbm], [1.9.0], [bug-gdbm@gnu.org]) 17m4_define([_GDBM_VERSION_MAJOR], 1)
18m4_define([_GDBM_VERSION_MINOR], 9)
19m4_define([_GDBM_VERSION_PATCH], 0)
20
21AC_INIT([gdbm],
22 [_GDBM_VERSION_MAJOR._GDBM_VERSION_MINOR[]m4_ifdef([_GDBM_VERSION_PATCH],._GDBM_VERSION_PATCH)],
23 [bug-gdbm@gnu.org])
18AC_PREREQ(2.59) 24AC_PREREQ(2.59)
19AC_CONFIG_SRCDIR([src/gdbmdefs.h]) 25AC_CONFIG_SRCDIR([src/gdbmdefs.h])
20AC_CONFIG_AUX_DIR([build-aux]) 26AC_CONFIG_AUX_DIR([build-aux])
21AC_CONFIG_HEADERS([autoconf.h]) 27AC_CONFIG_HEADERS([autoconf.h])
22AC_CONFIG_MACRO_DIR([m4]) 28AC_CONFIG_MACRO_DIR([m4])
23AM_INIT_AUTOMAKE([1.8.5 std-options]) 29AM_INIT_AUTOMAKE([1.8.5 std-options])
24 30
31AC_SUBST([GDBM_VERSION_MAJOR], _GDBM_VERSION_MAJOR)
32AC_SUBST([GDBM_VERSION_MINOR], _GDBM_VERSION_MINOR)
33AC_SUBST([GDBM_VERSION_PATCH], m4_ifdef([_GDBM_VERSION_PATCH],_GDBM_VERSION_PATCH,0))
34
25AC_ARG_ENABLE([memory-mapped-io], 35AC_ARG_ENABLE([memory-mapped-io],
26 AC_HELP_STRING( 36 AC_HELP_STRING(
27 [--enable-memory-mapped-io] 37 [--enable-memory-mapped-io]
28 [Use mmap(2) for disk I/O. (Default is YES.)]), 38 [Use mmap(2) for disk I/O. (Default is YES.)]),
29 [mapped_io=$enableval], 39 [mapped_io=$enableval],
30 [mapped_io=yes]) 40 [mapped_io=yes])
@@ -98,10 +108,11 @@ AM_CONDITIONAL([ENABLE_EXPORT], [test "$want_export" = yes])
98AC_CONFIG_TESTDIR(tests) 108AC_CONFIG_TESTDIR(tests)
99AC_CONFIG_FILES([tests/Makefile tests/atlocal]) 109AC_CONFIG_FILES([tests/Makefile tests/atlocal])
100AM_MISSING_PROG([AUTOM4TE], [autom4te]) 110AM_MISSING_PROG([AUTOM4TE], [autom4te])
101 111
102AC_CONFIG_FILES([Makefile 112AC_CONFIG_FILES([Makefile
103 src/Makefile 113 src/Makefile
114 src/gdbm.h
104 doc/Makefile 115 doc/Makefile
105 compat/Makefile 116 compat/Makefile
106 export/Makefile]) 117 export/Makefile])
107AC_OUTPUT 118AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.