aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2018-05-19 22:59:10 +0300
committerSergey Poznyakoff <gray@gnu.org>2018-05-19 22:59:10 +0300
commit008b71a4d58ad33cf5a41e2aa55b9393e8420531 (patch)
tree2923a1840dcd1c2108bfe13b6817bfd8ddcc19d2 /configure.ac
parent0f0c3dba3f676bf7a163586855f07ef427da3b4a (diff)
downloadgdbm-008b71a4d58ad33cf5a41e2aa55b9393e8420531.tar.gz
gdbm-008b71a4d58ad33cf5a41e2aa55b9393e8420531.tar.bz2
Remove gdbm-1.8.3 compatibility layer
* configure.ac: Remove gdbm-1.8.3 compatibility layer. Version 1.14.90 * Makefile.am (ACLOCAL_AMFLAGS): Remove deprecated variable. (MAYBE_EXPORT): Remove variable and conditional. * NEWS: Update. * NOTE-WARNING: Update. * README: Update. * doc/gdbm.texi: Update. * export/.gitignore: Remove. * export/Makefile.am: Remove. * export/export.c: Remove.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 2 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index 3511f0d..25c4ff4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,13 +14,13 @@
14# 14#
15# You should have received a copy of the GNU General Public License 15# You should have received a copy of the GNU General Public License
16# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */ 16# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
17 17
18m4_define([_GDBM_VERSION_MAJOR], 1) 18m4_define([_GDBM_VERSION_MAJOR], 1)
19m4_define([_GDBM_VERSION_MINOR], 14) 19m4_define([_GDBM_VERSION_MINOR], 14)
20m4_define([_GDBM_VERSION_PATCH], 1) 20m4_define([_GDBM_VERSION_PATCH], 90)
21 21
22AC_INIT([gdbm], 22AC_INIT([gdbm],
23 _GDBM_VERSION_MAJOR._GDBM_VERSION_MINOR[]m4_ifdef([_GDBM_VERSION_PATCH],._GDBM_VERSION_PATCH), 23 _GDBM_VERSION_MAJOR._GDBM_VERSION_MINOR[]m4_ifdef([_GDBM_VERSION_PATCH],._GDBM_VERSION_PATCH),
24 [bug-gdbm@gnu.org],, 24 [bug-gdbm@gnu.org],,
25 [http://www.gnu.org/software/gdbm]) 25 [http://www.gnu.org/software/gdbm])
26AC_PREREQ(2.69) 26AC_PREREQ(2.69)
@@ -50,40 +50,12 @@ AC_ARG_ENABLE([libgdbm-compat],
50 [Build and install libgdbm_compat. (Default is NO.)]), 50 [Build and install libgdbm_compat. (Default is NO.)]),
51 [want_compat=$enableval], 51 [want_compat=$enableval],
52 [want_compat=no]) 52 [want_compat=no])
53AC_ARG_VAR([COMPATINCLUDEDIR],[installation directory for dbm.h and ndbm.h]) 53AC_ARG_VAR([COMPATINCLUDEDIR],[installation directory for dbm.h and ndbm.h])
54test -z "$COMPATINCLUDEDIR" && COMPATINCLUDEDIR='$(includedir)' 54test -z "$COMPATINCLUDEDIR" && COMPATINCLUDEDIR='$(includedir)'
55 55
56AC_ARG_ENABLE([gdbm-export],
57 AC_HELP_STRING(
58 [--enable-gdbm-export],
59 [Build and install gdbmexport with specified gdbm 1.8 library. (Default is NO.)]),
60 [want_export=$enableval],
61 [want_export=no])
62
63AC_ARG_WITH([gdbm183-library],
64 AC_HELP_STRING(
65 [--with-gdbm183-library],
66 [Build gdbmexport with specified (static) library.]),
67 [GDBM183_LIBRARY=$withval],
68 [GDBM183_LIBRARY="-lgdbm"])
69
70AC_ARG_WITH([gdbm183-libdir],
71 AC_HELP_STRING(
72 [--with-gdbm183-libdir],
73 [Build gdbmexport with the gdbm library in the specified directory.]),
74 [GDBM183_LIBDIR=$withval],
75 [GDBM183_LIBDIR="/usr/local/lib"])
76
77AC_ARG_WITH([gdbm183-includedir],
78 AC_HELP_STRING(
79 [--with-gdbm183-includedir],
80 [Build gdbmexport with gdbm.h in the specified directory.]),
81 [GDBM183_INCLUDEDIR=$withval],
82 [GDBM183_INCLUDEDIR="/usr/local/include"])
83
84dnl Check for programs 56dnl Check for programs
85AC_PROG_CC 57AC_PROG_CC
86AC_PROG_CPP 58AC_PROG_CPP
87AC_PROG_INSTALL 59AC_PROG_INSTALL
88AC_PROG_LIBTOOL 60AC_PROG_LIBTOOL
89AC_PROG_YACC 61AC_PROG_YACC
@@ -129,17 +101,13 @@ then
129 AC_CHECK_FUNCS([msync]) 101 AC_CHECK_FUNCS([msync])
130fi 102fi
131AC_TYPE_OFF_T 103AC_TYPE_OFF_T
132AC_CHECK_SIZEOF(off_t) 104AC_CHECK_SIZEOF(off_t)
133AC_CHECK_MEMBERS([struct stat.st_blksize]) 105AC_CHECK_MEMBERS([struct stat.st_blksize])
134 106
135AC_SUBST(GDBM183_LIBRARY)
136AC_SUBST(GDBM183_LIBDIR)
137AC_SUBST(GDBM183_INCLUDEDIR)
138AM_CONDITIONAL([COMPAT_OPT], [test "$want_compat" = yes]) 107AM_CONDITIONAL([COMPAT_OPT], [test "$want_compat" = yes])
139AM_CONDITIONAL([ENABLE_EXPORT], [test "$want_export" = yes])
140 108
141# Check for Curses libs. 109# Check for Curses libs.
142for lib in ncurses curses termcap 110for lib in ncurses curses termcap
143do 111do
144 AC_CHECK_LIB($lib, tputs, [CURSES_LIBS="-l$lib"; break]) 112 AC_CHECK_LIB($lib, tputs, [CURSES_LIBS="-l$lib"; break])
145done 113done
@@ -211,28 +179,25 @@ AC_CONFIG_COMMANDS([status],[
211cat <<EOF 179cat <<EOF
212 180
213******************************************************************* 181*******************************************************************
214GDBM settings summary: 182GDBM settings summary:
215 183
216Compatibility library ......................... $status_compat 184Compatibility library ......................... $status_compat
217Compatibility export tool ..................... $status_export
218Memory mapped I/O ............................. $mapped_io 185Memory mapped I/O ............................. $mapped_io
219GNU Readline .................................. $status_readline 186GNU Readline .................................. $status_readline
220Debugging support ............................. $status_debug 187Debugging support ............................. $status_debug
221******************************************************************* 188*******************************************************************
222 189
223EOF 190EOF
224], 191],
225[status_compat=$want_compat 192[status_compat=$want_compat
226status_export=$want_export
227mapped_io=$mapped_io 193mapped_io=$mapped_io
228status_readline=$status_readline 194status_readline=$status_readline
229status_debug=$status_debug]) 195status_debug=$status_debug])
230 196
231AC_CONFIG_FILES([Makefile 197AC_CONFIG_FILES([Makefile
232 src/Makefile 198 src/Makefile
233 src/gdbm.h 199 src/gdbm.h
234 doc/Makefile 200 doc/Makefile
235 compat/Makefile 201 compat/Makefile])
236 export/Makefile])
237 202
238AC_OUTPUT 203AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.