aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2018-05-19 22:59:10 +0300
committerSergey Poznyakoff <gray@gnu.org>2018-05-19 22:59:10 +0300
commit008b71a4d58ad33cf5a41e2aa55b9393e8420531 (patch)
tree2923a1840dcd1c2108bfe13b6817bfd8ddcc19d2 /configure.ac
parent0f0c3dba3f676bf7a163586855f07ef427da3b4a (diff)
downloadgdbm-008b71a4d58ad33cf5a41e2aa55b9393e8420531.tar.gz
gdbm-008b71a4d58ad33cf5a41e2aa55b9393e8420531.tar.bz2
Remove gdbm-1.8.3 compatibility layer
* configure.ac: Remove gdbm-1.8.3 compatibility layer. Version 1.14.90 * Makefile.am (ACLOCAL_AMFLAGS): Remove deprecated variable. (MAYBE_EXPORT): Remove variable and conditional. * NEWS: Update. * NOTE-WARNING: Update. * README: Update. * doc/gdbm.texi: Update. * export/.gitignore: Remove. * export/Makefile.am: Remove. * export/export.c: Remove.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 2 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index 3511f0d..25c4ff4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,3 +19,3 @@ m4_define([_GDBM_VERSION_MAJOR], 1)
19m4_define([_GDBM_VERSION_MINOR], 14) 19m4_define([_GDBM_VERSION_MINOR], 14)
20m4_define([_GDBM_VERSION_PATCH], 1) 20m4_define([_GDBM_VERSION_PATCH], 90)
21 21
@@ -55,30 +55,2 @@ test -z "$COMPATINCLUDEDIR" && COMPATINCLUDEDIR='$(includedir)'
55 55
56AC_ARG_ENABLE([gdbm-export],
57 AC_HELP_STRING(
58 [--enable-gdbm-export],
59 [Build and install gdbmexport with specified gdbm 1.8 library. (Default is NO.)]),
60 [want_export=$enableval],
61 [want_export=no])
62
63AC_ARG_WITH([gdbm183-library],
64 AC_HELP_STRING(
65 [--with-gdbm183-library],
66 [Build gdbmexport with specified (static) library.]),
67 [GDBM183_LIBRARY=$withval],
68 [GDBM183_LIBRARY="-lgdbm"])
69
70AC_ARG_WITH([gdbm183-libdir],
71 AC_HELP_STRING(
72 [--with-gdbm183-libdir],
73 [Build gdbmexport with the gdbm library in the specified directory.]),
74 [GDBM183_LIBDIR=$withval],
75 [GDBM183_LIBDIR="/usr/local/lib"])
76
77AC_ARG_WITH([gdbm183-includedir],
78 AC_HELP_STRING(
79 [--with-gdbm183-includedir],
80 [Build gdbmexport with gdbm.h in the specified directory.]),
81 [GDBM183_INCLUDEDIR=$withval],
82 [GDBM183_INCLUDEDIR="/usr/local/include"])
83
84dnl Check for programs 56dnl Check for programs
@@ -134,7 +106,3 @@ AC_CHECK_MEMBERS([struct stat.st_blksize])
134 106
135AC_SUBST(GDBM183_LIBRARY)
136AC_SUBST(GDBM183_LIBDIR)
137AC_SUBST(GDBM183_INCLUDEDIR)
138AM_CONDITIONAL([COMPAT_OPT], [test "$want_compat" = yes]) 107AM_CONDITIONAL([COMPAT_OPT], [test "$want_compat" = yes])
139AM_CONDITIONAL([ENABLE_EXPORT], [test "$want_export" = yes])
140 108
@@ -216,3 +184,2 @@ GDBM settings summary:
216Compatibility library ......................... $status_compat 184Compatibility library ......................... $status_compat
217Compatibility export tool ..................... $status_export
218Memory mapped I/O ............................. $mapped_io 185Memory mapped I/O ............................. $mapped_io
@@ -225,3 +192,2 @@ EOF
225[status_compat=$want_compat 192[status_compat=$want_compat
226status_export=$want_export
227mapped_io=$mapped_io 193mapped_io=$mapped_io
@@ -234,4 +200,3 @@ AC_CONFIG_FILES([Makefile
234 doc/Makefile 200 doc/Makefile
235 compat/Makefile 201 compat/Makefile])
236 export/Makefile])
237 202

Return to:

Send suggestions and report system problems to the System administrator.