aboutsummaryrefslogtreecommitdiff
path: root/dicoclient/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'dicoclient/setup.py')
-rw-r--r--dicoclient/setup.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/dicoclient/setup.py b/dicoclient/setup.py
new file mode 100644
index 0000000..265264a
--- /dev/null
+++ b/dicoclient/setup.py
@@ -0,0 +1,39 @@
+#!/usr/bin/env python
+#
+# This file is part of GNU Dico.
+# Copyright (C) 2008-2009, 2012 Wojciech Polak
+#
+# GNU Dico is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Dico is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Dico. If not, see <http://www.gnu.org/licenses/>.
+
+from distutils.core import setup
+import dicoclient
+
+setup(name='dicoclient',
+ version='1.0',
+ author='Wojciech Polak',
+ author_email='polak@gnu.org',
+ url='http://www.gnu.org/software/dico/',
+ py_modules=['dicoclient', 'dicoshell'],
+ license='GPL License',
+ description='A DICT protocol (RFC 2229) client library.',
+ platforms=['any'],
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules'
+ ]
+)

Return to:

Send suggestions and report system problems to the System administrator.