aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index bb3d940..5229bba 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,8 +1,8 @@
# This file is part of Gamma.
-# Copyright (C) 2002, 2007, 2010 Sergey Poznyakoff
+# Copyright (C) 2002, 2007, 2010, 2015 Sergey Poznyakoff
#
# Gamma is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
@@ -22,12 +22,13 @@ gamma_TEXINFOS=\
expat.texi\
syslog.texi\
sql.texi
EXTRA_DIST = \
gendocs_template\
+ gendocs.sh\
mastermenu.el\
untabify.el
clean-local:
@rm -rf manual
@@ -89,13 +90,13 @@ check-unrevised:
rm $@-t; \
fi
all-check-docs: check-format \
check-refs check-fixmes check-writeme check-unrevised
-check-docs:
+check-docs:
@$(MAKE) -k all-check-docs
#
master-menu:
-$(AM_V_GEN)grep -q '^@detailmenu' $(info_TEXINFOS) && \
@@ -108,23 +109,23 @@ final: untabify master-menu
# The rendering level is one of PUBLISH, DISTRIB or PROOF.
# Just call `make RENDITION=PROOF [target]' if you want PROOF rendition.
MAKEINFOFLAGS=-D$(RENDITION)
-GENDOCS=gendocs.sh
+GENDOCS=$(srcdir)/gendocs.sh
-TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E
+TEXI2DVI=texi2dvi -t '@set $(RENDITION)'
# Make sure you set TEXINPUTS.
# TEXINPUTS=/usr/share/texmf/pdftex/plain/misc/ is ok for most distributions
.PHONY: manual
manual:
TEXINPUTS=$(srcdir):$(top_srcdir)/build-aux:$(TEXINPUTS) \
MAKEINFO="$(MAKEINFO) $(MAKEINFOFLAGS)" \
TEXI2DVI="$(TEXI2DVI) -t @finalout" \
- $(GENDOCS) --texi2html $(PACKAGE) '$(PACKAGE_NAME) manual'
+ $(GENDOCS) --no-copy-images $(PACKAGE) '$(PACKAGE_NAME) manual'
manual.tar.bz2: manual
tar cfj manual.tar.bz2 manual
man-tar: manual.tar.bz2

Return to:

Send suggestions and report system problems to the System administrator.