aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 33 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4f3b6e4..483b882 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,12 +16,12 @@ dnl along with Gamma. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.63)
-AC_INIT(gamma, 1.99, [gray@gnu.org.ua])
+AC_INIT(gamma, [1.99.99], [gray+gamma@gnu.org.ua])
AC_CONFIG_SRCDIR(src/guile-sql.h)
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_SYSTEM
-AM_INIT_AUTOMAKE([1.11.1 gnu tar-ustar silent-rules])
+AM_INIT_AUTOMAKE([1.11.1 gnu tar-ustar readme-alpha silent-rules])
AC_CONFIG_HEADERS([config.h])
# Enable silent rules by default:
@@ -74,6 +74,36 @@ if test -z "$GAMMA_LIB_LIST"; then
AC_MSG_ERROR([Nothing to build!])
fi
-AC_CONFIG_FILES(Makefile src/Makefile scripts/Makefile examples/Makefile)
+# Doc hints.
+# Select a rendition level:
+# DISTRIB for stable releases (at most one dot in the version number)
+# and maintenance releases (two dots, patchlevel < 50)
+# PROOF for alpha releases.
+# PUBLISH can only be required manually when running make in doc/
+AC_SUBST(RENDITION)
+case `echo $VERSION|sed 's/[[^.]]//g'` in
+""|".") RENDITION=DISTRIB;;
+"..") if test `echo $VERSION | sed 's/.*\.//'` -lt 50; then
+ RENDITION=DISTRIB
+ else
+ RENDITION=PROOF
+ fi;;
+*) RENDITION=PROOF;;
+esac
+
+if test $RENDITION = "PROOF"; then
+ if test -r $srcdir/git-describe; then
+ GIT_DESCRIBE=`sed '2,$d' $srcdir/git-describe`
+ AC_DEFINE_UNQUOTED([GIT_DESCRIBE], "$GIT_DESCRIBE",
+ [The most recent git tag])
+ fi
+fi
+
+
+AC_CONFIG_FILES(Makefile
+ src/Makefile
+ scripts/Makefile
+ examples/Makefile
+ doc/Makefile)
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.