aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2018-08-22 09:49:59 +0300
committerSergey Poznyakoff <gray@gnu.org>2018-08-22 11:23:16 +0300
commitf92dfd663dc50d9aac704c8df5ca48f5e35b8571 (patch)
tree48542f3bb6c0961db678cad49c0ce94d70793f6d /src/Makefile.am
parent6abb2548315b9db2925194e54f09f01126182f81 (diff)
downloadgamma-f92dfd663dc50d9aac704c8df5ca48f5e35b8571.tar.gz
gamma-f92dfd663dc50d9aac704c8df5ca48f5e35b8571.tar.bz2
Change library loading algorithm.
If the environment variable LD_LIBRARY_PATH is set, the loadable modules are first looked up in the directories listed in that variable, and then in the extension installation directory. Two attempts are made for each directory: first the library name with the -v-VERSION suffix is tried, then the library name without that suffix. * src: Rename to gamma * Makefile.am (SUBDIRS): Update. * configure.ac: Update. * scripts/bootstrap (srcdir, makefile): Update. * gamma/loader.sci: New file. * gamma/Makefile.am: Build loader.scm * src/sql.sci: Remove. * gamma/sql.scm: New file. * modules/sql (scm): Update. * src/syslog.sci: Remove. * gamma/syslog.scm: New file. * modules/syslog (scm): Update. * src/expat.sci: Remove. * gamma/expat.scm: New file. * modules/expat (scm): Update.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am48
1 files changed, 0 insertions, 48 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index c5caa7f..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,48 +0,0 @@
-# This file is part of Gamma.
-# Copyright (C) 2002, 2007, 2010, 2015 Sergey Poznyakoff
-#
-# Gamma is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# Gamma is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with Gamma. If not, see <http://www.gnu.org/licenses/>.
-
-AM_CPPFLAGS =\
- -I$(top_builddir)\
- -I$(srcdir)\
- -I.\
- @INCLUDEPATH@\
- -DDATADIR=\"$(guiledir)\"
-
-EXTRA_DIST = modules.mk documentation.sci
-EXTRA_LTLIBRARIES=
-lib_LTLIBRARIES=@GAMMA_LIB_LIST@
-install-data-hook: @GAMMA_INSTALL_HOOKS@
-MAINTAINERCLEANFILES=
-
-include modules.mk
-
-sitedir=$(GUILE_SITE)/$(PACKAGE)
-site_DATA=$(GAMMA_BUILT_DATA_FILES) documentation.scm
-
-.sci.scm:
- $(AM_V_GEN)m4 -DVERSION=$(VERSION) -DLIBDIR=$(libdir) \
- -DBUILDDIR="`pwd`" -DSITEDIR='$(sitedir)' $< > $@
-
-DOT_X_FILES=$(GAMMA_X_FILES)
-DOT_DOC_FILES=$(DOT_X_FILES:.x=.doc)
-
-DISTCLEANFILES=$(site_DATA)
-
-SUFFIXES=
-CLEANFILES=
-BUILT_SOURCES=
-include ../gint/gint.mk
-

Return to:

Send suggestions and report system problems to the System administrator.