aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-03-08 20:38:54 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2010-03-08 20:38:54 +0200
commit72cd81f502f8b609d3f551107cfc572c4e3ec7c8 (patch)
tree2c5d0509b010fd717aa5bea86686b0af510b44e5 /configure.ac
parent47e8375965170ebe93579f207ca9b5977e7b3f1c (diff)
downloadgamma-72cd81f502f8b609d3f551107cfc572c4e3ec7c8.tar.gz
gamma-72cd81f502f8b609d3f551107cfc572c4e3ec7c8.tar.bz2
Rewrite module bootstrap system.
* autogen.sh: Removed. * scripts/bootstrap: New file. * README-hacking: New file. * modules/MODLIST: New file. * modules/sql: New file. * modules/syslog: New file. * Makefile.am (dist-hook): Distribute modules/. * README: Update. * configure.ac: Remove module-specific stuff. Call gamma_MODCONFIG instead. * scripts/Makefile.am (EXTRA_DIST): Add bootstrap. * src/Makefile.am: Remove module-specific stuff. Include modules.mk instead. * .gitignore, src/.gitignore: Update
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac72
1 files changed, 7 insertions, 65 deletions
diff --git a/configure.ac b/configure.ac
index 31793a7..4f3b6e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,79 +59,21 @@ AC_MSG_RESULT($LIBS)
dnl Checks for libraries.
MU_CHECK_GUILE
+if test $mu_cv_lib_guile != yes; then
+ AC_MSG_ERROR([Guile not found])
+fi
+
dnl Checks for library functions.
AC_HEADER_STDC
-if test $mu_cv_lib_guile = yes; then
- MYSQL=yes
- PGSQL=yes
-
- AC_ARG_WITH([mysql],
- AC_HELP_STRING([--without-mysql],
- [configure to work without MySQL]),
- [MYSQL=$withval])
- AC_ARG_WITH([postgres],
- AC_HELP_STRING([--without-postgres],
- [configure to work without Postgres]),
- [PGSQL=$withval])
-
- SQLLIBS=""
- # Check individual libraries
- MU_CHECK_LIB([mysqlclient], [mysql_real_connect], [-lm],
- [ AC_DEFINE([USE_SQL_MYSQL],1,
- [Define this if you are going to use MySQL])
- AC_DEFINE([HAVE_LIBMYSQL],1,
- [Define this if you have mysqlclient library])
- SQLLIBS="$SQLLIBS $mu_cv_lib_mysqlclient" ],
- [ MYSQL=no ],
- [/usr/local/lib/mysql /usr/lib/mysql])
-
- MU_CHECK_LIB([pq], [PQconnectStart], [],
- [ AC_DEFINE([USE_SQL_PGSQL],1,
- [Define this if you are going to use PostgreSQL])
- AC_DEFINE([HAVE_LIBPQ],1,
- [Define this if you have libp])
- SQLLIBS="$SQLLIBS $mu_cv_lib_pq" ],
- [ PGSQL=no ],
- [/usr/local/pgsql/lib /usr/pgsql/lib])
+dnl Modules
- if test "x$SQLLIBS" != "x"; then
- LIBS="$LIBS $SQLLIBS"
- BUILD_LIBS="$BUILD_LIBS \$(LIB_SQL)"
- BUILD_DATA="$BUILD_DATA \$(SCM_SQL)"
- BUILD_X="$BUILD_X \$(X_SQL)"
- INSTALL_HOOKS="$INSTALL_HOOKS install-sql-hook"
+gamma_MODCONFIG
- if test $MYSQL = yes ; then
- AC_LIBOBJ([mysql])
- fi
- if test $PGSQL = yes ; then
- AC_LIBOBJ([pgsql])
- fi
- fi
-
- want_syslog=yes
- AC_ARG_WITH([syslog],
- AC_HELP_STRING([--without-syslog],
- [do not include syslog interfaces]),
- [want_syslog=$withval])
- if test $want_syslog = yes; then
- BUILD_LIBS="$BUILD_LIBS \$(LIB_SYSLOG)"
- BUILD_DATA="$BUILD_DATA \$(SCM_SYSLOG)"
- BUILD_X="$BUILD_X \$(X_SYSLOG)"
- INSTALL_HOOKS="$INSTALL_HOOKS install-syslog-hook"
- fi
-fi
-
-if test x"$BUILD_LIBS" = x; then
+if test -z "$GAMMA_LIB_LIST"; then
AC_MSG_ERROR([Nothing to build!])
fi
-AC_SUBST(BUILD_LIBS)
-AC_SUBST(BUILD_DATA)
-AC_SUBST(BUILD_X)
-AC_SUBST(INSTALL_HOOKS)
-
AC_CONFIG_FILES(Makefile src/Makefile scripts/Makefile examples/Makefile)
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.