summaryrefslogtreecommitdiff
path: root/mimetypes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mimetypes/Makefile.am')
-rw-r--r--mimetypes/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/mimetypes/Makefile.am b/mimetypes/Makefile.am
index cdcb0f1..3517a76 100644
--- a/mimetypes/Makefile.am
+++ b/mimetypes/Makefile.am
@@ -12,7 +12,18 @@ libmimetypes_a_SOURCES = \
locus.h\
prloc.c\
yyloc.h
-EXTRA_DIST=grammar.h
-AM_YFLAGS=-vtd
-AM_LEXFLAGS=-d
+
+# Notes on prefix renaming:
+# 1) bison and flex are required
+# 2) The following symbols must be renamed manually in lexer.l:
+# yylval, yylloc, yyerror. We do so by inserting appropriate
+# #defines immediately after the #include block.
+# 3) flex --prefix also renames the output root, so LEX_OUTPUT_ROOT
+# must be redefined to compensate for it.
+# In general, all of the above is a terrible kludge. I'd be better off
+# using gylwrap from GNU mailutils.
+AM_YFLAGS=-v -t -d --name-prefix=yymt
+AM_LFLAGS=-d --prefix=yymt
+LEX_OUTPUT_ROOT=lex.yymt
+
SUBDIRS = . tests

Return to:

Send suggestions and report system problems to the System administrator.