aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2020-01-18 17:18:42 +0200
committerSergey Poznyakoff <gray@gnu.org>2020-01-19 09:45:55 +0200
commite3d9037c37a934718c9bc8fb196006fa7c002ac0 (patch)
tree29a36b983d14afe9ba89e7d4128ce00a8cec09e9 /Makefile.PL
downloadfile-backup-e3d9037c37a934718c9bc8fb196006fa7c002ac0.tar.gz
file-backup-e3d9037c37a934718c9bc8fb196006fa7c002ac0.tar.bz2
Initial commit
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL34
1 files changed, 34 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..84b1f32
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,34 @@
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+use Module::Metadata;
+
+WriteMakefile(
+ NAME => 'File::Backup',
+ VERSION_FROM => 'lib/File/Backup.pm',
+ ABSTRACT_FROM => 'lib/File/Backup.pm',
+ LICENSE => 'gpl_3',
+ AUTHOR => 'Sergey Poznyakoff <gray@gnu.org>',
+ MIN_PERL_VERSION => 5.006,
+ PREREQ_PM => {
+ 'File::Temp' => 0.23
+ },
+ TEST_REQUIRES => {
+ 'File::Cmp' => 1.07
+ },
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {
+ repository => {
+ type => 'git',
+ url => 'git://git.gnu.org.ua/file-backup.git',
+ web => 'http://git.gnu.org.ua/cgit/file-backup.git/',
+ },
+ },
+ provides => Module::Metadata->provides(version => '1.4',
+ dir => 'lib')
+ }
+);
+
+
+

Return to:

Send suggestions and report system problems to the System administrator.